summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Hernberg2015-06-14 13:09:49 +0200
committerJoakim Hernberg2015-06-14 13:09:49 +0200
commit7efe56fa5c1d0124b00c9e13416f7885c1c14b2f (patch)
treeb5b34335c2b555e7991b7342d4fe3a215355964d
downloadaur-7efe56fa5c1d0124b00c9e13416f7885c1c14b2f.tar.gz
initial commit of wineasio (0.9.2-6)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD56
-rw-r--r--wineasio.install10
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b2a24795989
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Sun Jun 14 11:08:13 UTC 2015
+pkgbase = wineasio
+ pkgdesc = ASIO driver implementation for Wine
+ pkgver = 0.9.2
+ pkgrel = 6
+ url = http://sourceforge.net/projects/wineasio/
+ install = wineasio.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ed
+ makedepends = steinberg-asio
+ depends = wine
+ depends = jack
+ source = http://downloads.sourceforge.net/wineasio/wineasio-0.9.2.tar.gz
+ sha256sums = 9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b
+ depends_x86_64 = lib32-jack
+ makedepends_x86_64 = gcc-multilib
+
+pkgname = wineasio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f1e742f2757
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Joakim Hernberg <jhernberg@alchemy.lu>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
+
+pkgname=wineasio
+pkgver=0.9.2
+pkgrel=6
+
+pkgdesc="ASIO driver implementation for Wine"
+url="http://sourceforge.net/projects/wineasio/"
+arch=('i686' 'x86_64')
+license=('LGPL')
+
+depends=('wine' 'jack')
+depends_x86_64+=('lib32-jack')
+makedepends=('ed' 'steinberg-asio')
+makedepends_x86_64+=('gcc-multilib')
+
+install="$pkgname".install
+
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b')
+
+prepare() {
+ cd "$pkgname"
+ cp /usr/include/steinberg-asio/asio.h asio.h
+ if [[ "$CARCH" == x86_64 ]]; then
+ cp asio.h asio.h.i686
+ ./prepare_64bit_asio
+ fi
+}
+
+build() {
+ cd "$pkgname"
+ if [[ "$CARCH" == x86_64 ]]; then
+ make -f Makefile64
+ mv "$pkgname".dll.so "$pkgname".dll.so.x86_64
+ cp asio.h.i686 asio.h
+ make clean
+ make
+ else
+ make
+ fi
+}
+
+package() {
+ cd "$pkgname"
+ if [[ "$CARCH" == x86_64 ]]; then
+ install -D -m755 "$pkgname".dll.so.x86_64 "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
+ install -D -m755 "$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
+ else
+ install -D -m755 "$pkgname".dll.so "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
+ fi
+ install -D -m644 README "$pkgdir"/usr/share/"$pkgname"/README
+}
+# vim:set ts=2 sw=2 et:
diff --git a/wineasio.install b/wineasio.install
new file mode 100644
index 000000000000..412c07d1b6c1
--- /dev/null
+++ b/wineasio.install
@@ -0,0 +1,10 @@
+post_install() {
+ . /etc/makepkg.conf
+ if [[ "$CARCH" = i686 ]]; then
+ echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)"
+ else
+ echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)" and
+ echo "please run \"wine64 regsvr32 wineasio.dll\" to register 64bit wineasio in your prefix (~/.wine)"
+ fi
+}
+# vim:set ts=2 sw=2 et: