summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmael González2020-07-18 19:02:53 +0200
committerIsmael González2020-07-18 19:02:53 +0200
commitbd1d87a99754591f4f6cddc8a53e1c91b428e469 (patch)
treea0a132b0dfea7fd7eef43266a8a9d06eccc44907
parent96aee677083bfa2dc406b2fc19b44b3387c60900 (diff)
downloadaur-bd1d87a99754591f4f6cddc8a53e1c91b428e469.tar.gz
Wineasio release 1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD51
-rw-r--r--wineasio.install12
3 files changed, 27 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ec51c577abd..63b1dfbb83bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = wineasio
pkgdesc = ASIO driver implementation for Wine
- pkgver = 0.9.2
- pkgrel = 7
- url = http://sourceforge.net/projects/wineasio/
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/wineasio/wineasio
install = wineasio.install
arch = i686
arch = x86_64
license = LGPL
- makedepends = steinberg-asio
depends = wine
depends = jack
- source = http://downloads.sourceforge.net/wineasio/wineasio-0.9.2.tar.gz
- source = wineasio-fix-prep64bit.patch::https://github.com/jhernberg/wineasio/pull/1.patch
- source = wineasio-fix-unicode-h.patch::https://github.com/jhernberg/wineasio/pull/10.patch
- sha256sums = 9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b
- sha256sums = 2789faed51992c6f6c1703cef8af3efdf26a3352bcef4b566de1979e69ab4b02
- sha256sums = 3b9081fc015724ab0661269ed66832a3b019b21f5f2ebbadae304aa9c63a39a4
+ depends = realtime-privileges
+ source = https://github.com/wineasio/wineasio/releases/download/v1.0.0/wineasio-1.0.0.tar.gz
+ sha256sums = b550d34e6c5ba3c2accffda96fa5624b725680d862227254372d1349a0b5587f
depends_x86_64 = lib32-jack
makedepends_x86_64 = gcc-multilib
diff --git a/PKGBUILD b/PKGBUILD
index 0cc975227675..85668ae67340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,45 @@
# Author: Joakim Hernberg <jhernberg@alchemy.lu>
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
-# Maintainer: redtide <redtid3@gmail.com>
+# Contributor: redtide <redtid3@gmail.com>
+# Maintainer: chuckdaniels <ismgonval@gmail.com>
pkgname=wineasio
-pkgver=0.9.2
-pkgrel=7
+pkgver=1.0.0
+pkgrel=1
pkgdesc="ASIO driver implementation for Wine"
-url="http://sourceforge.net/projects/wineasio/"
+url="https://github.com/wineasio/wineasio"
arch=('i686' 'x86_64')
license=('LGPL')
-depends=('wine' 'jack')
+depends=('wine' 'jack' 'realtime-privileges')
depends_x86_64+=('lib32-jack')
-makedepends=('steinberg-asio')
makedepends_x86_64+=('gcc-multilib')
install="$pkgname".install
source=(
- "http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
- "wineasio-fix-prep64bit.patch::https://github.com/jhernberg/wineasio/pull/1.patch"
- "wineasio-fix-unicode-h.patch::https://github.com/jhernberg/wineasio/pull/10.patch"
+ "https://github.com/wineasio/wineasio/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
)
sha256sums=(
- '9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b'
- '2789faed51992c6f6c1703cef8af3efdf26a3352bcef4b566de1979e69ab4b02'
- '3b9081fc015724ab0661269ed66832a3b019b21f5f2ebbadae304aa9c63a39a4'
+ 'b550d34e6c5ba3c2accffda96fa5624b725680d862227254372d1349a0b5587f'
)
-prepare() {
- cd "$pkgname"
- cp /usr/include/steinberg-asio/asio.h asio.h
- patch --forward --strip=1 --input="${srcdir}/wineasio-fix-unicode-h.patch"
- if [[ "$CARCH" == x86_64 ]]; then
- cp asio.h asio.h.i686
- patch --forward --strip=1 --input="${srcdir}/wineasio-fix-prep64bit.patch"
- ./prepare_64bit_asio
- fi
-}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
+ make 32
if [[ "$CARCH" == x86_64 ]]; then
- make -f Makefile64
- mv "$pkgname".dll.so "$pkgname".dll.so.x86_64
- cp asio.h.i686 asio.h
- make clean
- make
- else
- make
+ make 64
fi
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
if [[ "$CARCH" == x86_64 ]]; then
- install -D -m755 "$pkgname".dll.so.x86_64 "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
- install -D -m755 "$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
+ install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
+ install -D -m755 build64/"$pkgname".dll.so "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
else
- install -D -m755 "$pkgname".dll.so "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
+ install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
fi
- install -D -m644 README "$pkgdir"/usr/share/"$pkgname"/README
+ install -D -m644 README.md "$pkgdir"/usr/share/"$pkgname"/README.md
}
# vim:set ts=2 sw=2 et:
diff --git a/wineasio.install b/wineasio.install
index 412c07d1b6c1..e6347772fe73 100644
--- a/wineasio.install
+++ b/wineasio.install
@@ -1,10 +1,8 @@
post_install() {
- . /etc/makepkg.conf
- if [[ "$CARCH" = i686 ]]; then
- echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)"
- else
- echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)" and
- echo "please run \"wine64 regsvr32 wineasio.dll\" to register 64bit wineasio in your prefix (~/.wine)"
- fi
+ echo "You need to add your user to 'realtime' group to use wineasio."
+ echo ""
+ echo "You also need to register wineasio in you Wine prefix:"
+ echo "- For 32bit, run: regsvr32 wineasio.dll "
+ echo "- For 64bit, run: wine64 regsvr32 wineasio.dll "
}
# vim:set ts=2 sw=2 et: