summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWheelchairArtist2022-02-26 09:23:27 +0100
committerWheelchairArtist2022-02-26 09:23:27 +0100
commitef8927d072f4dbc732e907bd8a568215c7872701 (patch)
tree718f67f5b6db96709c7c26f7a88381f8465ba7fa
parent26c04f5b25de67447fb2505631e21a097e26cdc3 (diff)
downloadaur-ef8927d072f4dbc732e907bd8a568215c7872701.tar.gz
update to version 1.1.0, drop i686 support
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
-rw-r--r--wineasio.install11
3 files changed, 36 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ee75de55fdd..461cb4d0093c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = wineasio
pkgdesc = ASIO driver implementation for Wine
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/wineasio/wineasio
install = wineasio.install
- arch = i686
arch = x86_64
license = LGPL
- depends = wine
+ makedepends = gcc-multilib
depends = jack
+ depends = lib32-jack
depends = realtime-privileges
- source = https://github.com/wineasio/wineasio/releases/download/v1.0.0/wineasio-1.0.0.tar.gz
- sha256sums = b550d34e6c5ba3c2accffda96fa5624b725680d862227254372d1349a0b5587f
- depends_x86_64 = lib32-jack
- makedepends_x86_64 = gcc-multilib
+ depends = wine
+ source = https://github.com/wineasio/wineasio/releases/download/v1.1.0/wineasio-1.1.0.tar.gz
+ sha256sums = aa26ec986878d3fee1b99d0b31d0085379a78fcace20defbaf9627f007e2f2cc
pkgname = wineasio
-
diff --git a/PKGBUILD b/PKGBUILD
index a09020b6f502..27bdaee96b96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
# Contributor: redtide <redtid3@gmail.com>
-# Maintainer: Matthew Bakhtiari <contact@altf2.dev>
+# Contributor: Matthew Bakhtiari <contact@altf2.dev>
+# Maintainer: Kazel <address at domain dot tld>
pkgname=wineasio
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="ASIO driver implementation for Wine"
url="https://github.com/wineasio/wineasio"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('LGPL')
-depends=('wine' 'jack' 'realtime-privileges')
-depends_x86_64+=('lib32-jack')
-makedepends_x86_64+=('gcc-multilib')
+depends=('jack' 'lib32-jack' 'realtime-privileges' 'wine')
+makedepends=('gcc-multilib')
install="$pkgname".install
@@ -23,23 +23,29 @@ source=(
"https://github.com/wineasio/wineasio/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
)
sha256sums=(
- 'b550d34e6c5ba3c2accffda96fa5624b725680d862227254372d1349a0b5587f'
+ 'aa26ec986878d3fee1b99d0b31d0085379a78fcace20defbaf9627f007e2f2cc'
)
+
build() {
cd "$pkgname-$pkgver"
+
make 32
- if [[ "$CARCH" == x86_64 ]]; then
- make 64
- fi
+ cd build32
+ winebuild -m32 --dll --fake-module -E ../wineasio.dll.spec asio.c.o main.c.o regsvr.c.o > $pkgname.dll
+ cd ..
+
+ make 64
+ cd build64
+ winebuild -m64 --dll --fake-module -E ../wineasio.dll.spec asio.c.o main.c.o regsvr.c.o > $pkgname.dll
+ cd ..
}
+
package() {
cd "$pkgname-$pkgver"
- if [[ "$CARCH" == x86_64 ]]; then
- install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
- install -D -m755 build64/"$pkgname".dll.so "$pkgdir"/usr/lib/wine/"$pkgname".dll.so
- else
- install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/"$pkgname".dll.so
- fi
+ install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/i386-unix/"$pkgname".dll.sof
+ install -D -m644 build32/"$pkgname".dll "$pkgdir"/usr/lib32/wine/i386-windows/"$pkgname".dll
+ install -D -m755 build64/"$pkgname".dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/"$pkgname".dll.so
+ install -D -m644 build64/"$pkgname".dll "$pkgdir"/usr/lib/wine/x86_64-windows/"$pkgname".dll
install -D -m644 README.md "$pkgdir"/usr/share/"$pkgname"/README.md
}
# vim:set ts=2 sw=2 et:
diff --git a/wineasio.install b/wineasio.install
index e6347772fe73..2c10b7ac4adf 100644
--- a/wineasio.install
+++ b/wineasio.install
@@ -1,8 +1,9 @@
post_install() {
- echo "You need to add your user to 'realtime' group to use wineasio."
- echo ""
- echo "You also need to register wineasio in you Wine prefix:"
- echo "- For 32bit, run: regsvr32 wineasio.dll "
- echo "- For 64bit, run: wine64 regsvr32 wineasio.dll "
+echo "Your user must belong to the realtime group in order to use wineasio."
+echo "This can be done with sudo usermod -aG realtime $(whoami)"
+echo ""
+echo "For registering wineasio as an ASIO driver:"
+echo "For 32bit, run: regsvr32 /usr/lib32/wine/i386-windows/wineasio.dll"
+echo "For 64bit, run: wine64 regsvr32 /usr/lib/wine/x86_64-windows/wineasio.dll"
}
# vim:set ts=2 sw=2 et: