summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-10-13 17:58:19 -0400
committerTony Lambiris2018-10-13 17:58:19 -0400
commit40710e654891fda59e47349894c98e331179a0c9 (patch)
treedadeb98efe5fb6535e43347f9fa7cd34a7240d5f
downloadaur-40710e654891fda59e47349894c98e331179a0c9.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
-rw-r--r--wineasio.install10
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6af157d298a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wineasio-git
+ pkgdesc = WineASIO provides an ASIO to JACK driver for WINE.
+ pkgver = r50.4b23797
+ pkgrel = 1
+ url = https://github.com/jhernberg/wineasio
+ install = wineasio.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ed
+ makedepends = steinberg-asio
+ depends = wine
+ depends = jack
+ provides = wineasio
+ conflicts = wineasio
+ source = wineasio-git::git+https://github.com/jhernberg/wineasio
+ sha256sums = SKIP
+ depends_x86_64 = lib32-jack
+ makedepends_x86_64 = gcc-multilib
+
+pkgname = wineasio-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..728d2a85fdf7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+wineasio-git
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0d5faa98cbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=wineasio-git
+pkgver=r50.4b23797
+pkgrel=1
+pkgdesc='WineASIO provides an ASIO to JACK driver for WINE.'
+arch=('i686' 'x86_64')
+url='https://github.com/jhernberg/wineasio'
+license=(LGPL)
+
+depends=('wine' 'jack')
+depends_x86_64+=('lib32-jack')
+makedepends=('ed' 'steinberg-asio')
+makedepends_x86_64+=('gcc-multilib')
+conflicts=(wineasio)
+provides=(wineasio)
+
+install=wineasio.install
+source=("${pkgname}::git+https://github.com/jhernberg/wineasio")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ cp /usr/include/steinberg-asio/asio.h asio.h
+ if [[ "$CARCH" == x86_64 ]]; then
+ cp asio.h asio.h.i686
+ ./prepare_64bit_asio
+ fi
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ if [[ "$CARCH" == x86_64 ]]; then
+ make -f Makefile64
+ mv wineasio.dll.so wineasio.dll.so.x86_64
+ cp asio.h.i686 asio.h
+ make clean
+ fi
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ #make install PREFIX="$pkgdir/usr"
+
+ if [[ "$CARCH" == x86_64 ]]; then
+ install -D -m755 wineasio.dll.so.x86_64 "$pkgdir"/usr/lib/wine/wineasio.dll.so
+ install -D -m755 wineasio.dll.so "$pkgdir"/usr/lib32/wine/wineasio.dll.so
+ else
+ install -D -m755 wineasio.dll.so "$pkgdir"/usr/lib/wine/wineasio.dll.so
+ fi
+ install -D -m644 README "$pkgdir"/usr/share/"$pkgname"/README
+}
diff --git a/wineasio.install b/wineasio.install
new file mode 100644
index 000000000000..412c07d1b6c1
--- /dev/null
+++ b/wineasio.install
@@ -0,0 +1,10 @@
+post_install() {
+ . /etc/makepkg.conf
+ if [[ "$CARCH" = i686 ]]; then
+ echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)"
+ else
+ echo "Please run \"regsvr32 wineasio.dll\" to register 32bit wineasio in your prefix (~/.wine)" and
+ echo "please run \"wine64 regsvr32 wineasio.dll\" to register 64bit wineasio in your prefix (~/.wine)"
+ fi
+}
+# vim:set ts=2 sw=2 et: