summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2020-10-25 19:53:25 +0800
committerSamLukeYes2020-10-25 19:53:25 +0800
commit3efe94faf7f85c68475c0ffb5ea2efcd644b2832 (patch)
tree61707972e7e4cde50ff4153738a314a2664cb6e2
parent25921bc7458cd81ea2f0ea10e9694f95e63a67ef (diff)
downloadaur-3efe94faf7f85c68475c0ffb5ea2efcd644b2832.tar.gz
rewrite pkgbuild
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
-rw-r--r--winetricks-zh.install7
4 files changed, 36 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ffb38485e95..961e324e4beb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = winetricks-zh-git
pkgdesc = Wine Setup Wizard Winetricks Chinese Version
- pkgver = r127.02900ad
+ pkgver = r235.77e5348
pkgrel = 1
url = https://github.com/hillwoodroc/winetricks-zh
- install = winetricks-zh.install
arch = any
license = LGPL
makedepends = git
- depends = wine
- depends = curl
+ makedepends = bash
+ makedepends = wine
depends = cabextract
- depends = unrar
- depends = unzip
- depends = p7zip
optdepends = zenity: For the GTK3 GUI.
- optdepends = kdebase-kdialog: For the KDE GUI (less capable).
+ optdepends = kdialog: For the KDE GUI (less capable).
+ optdepends = aria2: For downloading. At least one download command should be available.
+ optdepends = wget: For downloading. At least one download command should be available.
+ optdepends = curl: For downloading. At least one download command should be available.
+ optdepends = binutils: For unpacking. If not available, will fall back to wine 7zip.
+ optdepends = unrar: For unpacking. If not available, will fall back to wine 7zip.
+ optdepends = unzip: For unpacking. If not available, will fall back to wine 7zip.
+ optdepends = p7zip: For unpacking. If not available, will fall back to wine 7zip.
optdepends = sudo: For automatically mounting ISO images.
optdepends = xdg-utils: For opening manual download pages.
optdepends = perl: For installing Steam.
+ optdepends = hicolor-icon-theme: Needed for hicolor theme hierarchy
source = winetricks-zh-git::git+https://github.com/hillwoodroc/winetricks-zh.git
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..61e51bf50b70
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+winetricks-zh-git/
+*.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 375a2c006cd7..c5048deb7ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
-# Maintainer: Bruce Zhang <zttt183525594@gmail.com>
+# Maintainer: Sam L. Yes <samlukeyes123@gmail.com>
+# Contributor: Bruce Zhang <zttt183525594@gmail.com>
+
pkgname=winetricks-zh-git
-pkgver=r127.02900ad
+pkgver=r235.77e5348
pkgrel=1
pkgdesc="Wine Setup Wizard Winetricks Chinese Version"
arch=('any')
url="https://github.com/hillwoodroc/winetricks-zh"
license=('LGPL')
-depends=('wine' 'curl' 'cabextract' 'unrar' 'unzip' 'p7zip')
-makedepends=('git')
+depends=('cabextract')
+makedepends=('git' 'bash' 'wine')
optdepends=('zenity: For the GTK3 GUI.'
- 'kdebase-kdialog: For the KDE GUI (less capable).'
+ 'kdialog: For the KDE GUI (less capable).'
+ 'aria2: For downloading. At least one download command should be available.'
+ 'wget: For downloading. At least one download command should be available.'
+ 'curl: For downloading. At least one download command should be available.'
+ 'binutils: For unpacking. If not available, will fall back to wine 7zip.'
+ 'unrar: For unpacking. If not available, will fall back to wine 7zip.'
+ 'unzip: For unpacking. If not available, will fall back to wine 7zip.'
+ 'p7zip: For unpacking. If not available, will fall back to wine 7zip.'
'sudo: For automatically mounting ISO images.'
'xdg-utils: For opening manual download pages.'
- 'perl: For installing Steam.')
-install=winetricks-zh.install
+ 'perl: For installing Steam.'
+ 'hicolor-icon-theme: Needed for hicolor theme hierarchy')
+#install=winetricks-zh.install
source=("$pkgname::git+https://github.com/hillwoodroc/winetricks-zh.git")
md5sums=('SKIP')
@@ -27,5 +37,7 @@ pkgver() {
package() {
cd "$pkgname"
- find ./ -type f -exec install -Dm755 {} "${pkgdir}/opt/winetricks-zh/{}" \;
+ install -Dm755 winetricks-zh ${pkgdir}/usr/bin/winetricks-zh
+ install -Dm644 icon/winetricks-zh.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/winetricks-zh.svg
+ install -Dm644 winetricks-zh.desktop ${pkgdir}/usr/share/applications/winetricks-zh.desktop
}
diff --git a/winetricks-zh.install b/winetricks-zh.install
deleted file mode 100644
index 813fd0c912d0..000000000000
--- a/winetricks-zh.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- ln -s /opt/winetricks-zh/winetricks-zh /usr/bin/winetricks-zh
-}
-
-post_remove() {
- rm /usr/bin/winetricks-zh
-}