summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Zhang2017-06-22 13:01:40 +0800
committerBruce Zhang2017-06-22 13:01:40 +0800
commitbcc28076021bdb6dfcf4ee661d9a7f55cd4f6160 (patch)
tree5a6ec30b4f4e190c1e3eac6bf3917545cf4835f8
downloadaur-bcc28076021bdb6dfcf4ee661d9a7f55cd4f6160.tar.gz
first release
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD31
-rw-r--r--winetricks-zh.install7
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83e277b6a8f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = winetricks-zh-git
+ pkgdesc = Wine Setup Wizard Winetricks Chinese Version
+ pkgver = r125.3012b9a
+ pkgrel = 1
+ url = https://github.com/hillwoodroc/winetricks-zh
+ install = winetricks-zh.install
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = wine
+ depends = curl
+ depends = cabextract
+ depends = unrar
+ depends = unzip
+ depends = p7zip
+ optdepends = zenity: For the GTK3 GUI.
+ optdepends = kdebase-kdialog: For the KDE GUI (less capable).
+ optdepends = sudo: For automatically mounting ISO images.
+ optdepends = xdg-utils: For opening manual download pages.
+ optdepends = perl: For installing Steam.
+ source = winetricks-zh-git::git+https://github.com/hillwoodroc/winetricks-zh.git
+ md5sums = SKIP
+
+pkgname = winetricks-zh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..031d525b4858
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bruce Zhang <zttt183525594@gmail.com>
+pkgname=winetricks-zh-git
+pkgver=r125.3012b9a
+pkgrel=1
+pkgdesc="Wine Setup Wizard Winetricks Chinese Version"
+arch=('any')
+url="https://github.com/hillwoodroc/winetricks-zh"
+license=('LGPL')
+depends=('wine' 'curl' 'cabextract' 'unrar' 'unzip' 'p7zip')
+makedepends=('git')
+optdepends=('zenity: For the GTK3 GUI.'
+ 'kdebase-kdialog: For the KDE GUI (less capable).'
+ 'sudo: For automatically mounting ISO images.'
+ 'xdg-utils: For opening manual download pages.'
+ 'perl: For installing Steam.')
+install=winetricks-zh.install
+source=("$pkgname::git+https://github.com/hillwoodroc/winetricks-zh.git")
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find ./ -type f -exec install -Dm755 {} "${pkgdir}/opt/winetricks-zh/{}" \;
+}
diff --git a/winetricks-zh.install b/winetricks-zh.install
new file mode 100644
index 000000000000..813fd0c912d0
--- /dev/null
+++ b/winetricks-zh.install
@@ -0,0 +1,7 @@
+post_install() {
+ ln -s /opt/winetricks-zh/winetricks-zh /usr/bin/winetricks-zh
+}
+
+post_remove() {
+ rm /usr/bin/winetricks-zh
+}