summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-09-17 12:27:57 +1000
committerJonathan Liu2015-09-17 12:27:57 +1000
commitc6c2ce92c708fc73ead43bc186e0b0d9074f5f70 (patch)
tree47d070055a2e20da512ebbd8b7cb8727feaa4795
downloadaur-c6c2ce92c708fc73ead43bc186e0b0d9074f5f70.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--samba4.patch12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6651dc95c494
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = winexe-git
+ pkgdesc = Remotely execute commands on Windows NT/2000/XP/2003 systems
+ pkgver = r234.b787d2a
+ pkgrel = 1
+ url = http://sourceforge.net/projects/winexe/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ depends = mingw-w64-gcc
+ depends = smbclient
+ provides = winexe
+ conflicts = winexe
+ options = !buildflags
+ source = git://git.code.sf.net/p/winexe/winexe-waf
+ source = samba4.patch
+ md5sums = SKIP
+ md5sums = 09379f3349f9ebefe2d11b90222110ad
+
+pkgname = winexe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..928682a78167
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=winexe-git
+_gitname=winexe-waf
+pkgver=r234.b787d2a
+pkgrel=1
+pkgdesc="Remotely execute commands on Windows NT/2000/XP/2003 systems"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/winexe/"
+license=('GPL3')
+depends=('mingw-w64-gcc' 'smbclient')
+makedepends=('python2')
+provides=('winexe')
+conflicts=('winexe')
+options=('!buildflags')
+source=("git://git.code.sf.net/p/winexe/${_gitname}"
+ "samba4.patch")
+md5sums=('SKIP'
+ '09379f3349f9ebefe2d11b90222110ad')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_gitname}/source"
+ patch -Np2 -i "${srcdir}/samba4.patch"
+}
+
+build() {
+ cd "${_gitname}/source"
+ python2 waf configure build --prefix="${pkgdir}/usr" --samba-inc-dirs=/usr/include/samba-4.0 --samba-lib-dirs=/usr/lib/samba
+}
+
+package() {
+ cd "${_gitname}/source"
+ python2 waf install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/samba4.patch b/samba4.patch
new file mode 100644
index 000000000000..3334f4e51345
--- /dev/null
+++ b/samba4.patch
@@ -0,0 +1,12 @@
+diff -Nur winexe-waf.orig/source/wscript winexe-waf/source/wscript
+--- winexe-waf.orig/source/wscript 2015-09-17 12:01:54.235640992 +1000
++++ winexe-waf/source/wscript 2015-09-17 12:02:18.188976190 +1000
+@@ -78,7 +78,7 @@
+ ''' % (h in 'smb_cli.h smb_cliraw.h smb_composite.h util/debug.h'.split(), h))
+
+ libs = []
+- for l in 'cli-ldap dcerpc dcerpc-samba errors popt talloc ndr-standard samba-hostconfig samba-credentials smbclient-raw'.split():
++ for l in 'cli-ldap-samba4 dcerpc-samba4 dcerpc-samba-samba4 errors-samba4 samba-debug-samba4 popt talloc ndr-standard samba-hostconfig samba-credentials smbclient-raw'.split():
+ if ctx.check(lib=l, libpath=ctx.env.SAMBA_LIBS, mandatory=False):
+ libs.append(l)
+ else: