summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-08-02 21:00:08 +0100
committerGrey Christoforo2018-08-02 21:00:08 +0100
commit60202fc3f941e8413acaa999bc121ca885df691e (patch)
treee7efc8c7bb9a1871d7d3c6e046e028e41f35f9d6
parentfe2469a32f64ce0aa34069ed1724788ed6dd83c3 (diff)
downloadaur-60202fc3f941e8413acaa999bc121ca885df691e.tar.gz
version bump
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2aaf7d5e0dc..ad476e4b12a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.0.12.1.5
+ pkgver = 6.1.0.1.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -12,24 +12,14 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.0.12/wingide-6.0.12-1-x86_64-linux.tar.bz2
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-remotely-stored-projects-6.0.12p1-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-vi-visual-bc-6.0.12p2-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-matplotlib-debug-6.0.12p3-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-logging-exc-6.0.12p4-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/avoid-lic-notify-6.0.12p5-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-wrap-6.0.12p6-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-exp-lic-flashing-6.0.12p7-all.tar
- source = http://wingware.com/pub/wingide/6.0.12/patches/fix-vi-c2w-6.0.12p8-all.tar
- md5sums = 74a72215aa827fe19049bea5d24382cc
- md5sums = 8ab32b0c575907db9603e6ed52b4fe69
- md5sums = caef531adab241abc9349259a82a5cf6
- md5sums = 1bd037a9f2b4b1ce3fc9d3a2e1c3213a
- md5sums = 3dd2a8fbec556973b2b432a085f2bb7d
- md5sums = c89995b2b11c11bc03064d7f7b69f562
- md5sums = 7bfeed59d6745f30a3cb3ca6fdb35bb1
- md5sums = 541fe8b4cb5c6a59a850a5f7d1417016
- md5sums = f64d157c497c1517cc6c6278c57174cc
+ source = http://wingware.com/pub/wingide/6.1.0/wingide-6.1.0-1-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p1-all.tar
+ source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p2-all.tar
+ source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-env-6.1.0p3-all.tar
+ md5sums = b4e5b7f9ec4be77e5e9e7e249b737b69
+ md5sums = f96618da2fe8a5d12e90e0027a6e23f8
+ md5sums = 45c443b9b1ef24be01139bb9e5610cfa
+ md5sums = 0dca244c6e605d9b4e9cb9fa0eed5b96
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 7f41dcdd5c07..4650c4dbe85f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.0.12
+_wingver=6.1.0
_wingrel=1
-_wing_patch_lvl=5 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
@@ -11,21 +11,16 @@ url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-remotely-stored-projects-6.0.12p1-all.tar" "fix-vi-visual-bc-6.0.12p2-all.tar" "fix-matplotlib-debug-6.0.12p3-all.tar" "fix-logging-exc-6.0.12p4-all.tar" "avoid-lic-notify-6.0.12p5-all.tar" "fix-wrap-6.0.12p6-all.tar" "fix-exp-lic-flashing-6.0.12p7-all.tar" "fix-vi-c2w-6.0.12p8-all.tar")
+_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('74a72215aa827fe19049bea5d24382cc'
- '8ab32b0c575907db9603e6ed52b4fe69'
- 'caef531adab241abc9349259a82a5cf6'
- '1bd037a9f2b4b1ce3fc9d3a2e1c3213a'
- '3dd2a8fbec556973b2b432a085f2bb7d'
- 'c89995b2b11c11bc03064d7f7b69f562'
- '7bfeed59d6745f30a3cb3ca6fdb35bb1'
- '541fe8b4cb5c6a59a850a5f7d1417016'
- 'f64d157c497c1517cc6c6278c57174cc')
+md5sums=('b4e5b7f9ec4be77e5e9e7e249b737b69'
+ 'f96618da2fe8a5d12e90e0027a6e23f8'
+ '45c443b9b1ef24be01139bb9e5610cfa'
+ '0dca244c6e605d9b4e9cb9fa0eed5b96')
install=${pkgname}.install