summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-17 13:38:20 +0000
committerGrey Christoforo2016-01-17 13:38:20 +0000
commit6f7a6897f4f59de4c0cff54f7777245a40a0b057 (patch)
tree1be75b8e396a110884ada36c5f080ca3e7eb0d4e
parentb3d457544ecfce0f56cd4ca545c5ac199e72688c (diff)
downloadaur-6f7a6897f4f59de4c0cff54f7777245a40a0b057.tar.gz
bump to ver 5.1.9-1 and add patch 5.1.9-1p1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eef06f3e9e3..df78768474df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
# Generated by mksrcinfo v8
-# Tue Dec 22 18:26:16 UTC 2015
+# Sun Jan 17 13:36:05 UTC 2016
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 5.1.8.1
+ pkgver = 5.1.9.1
pkgrel = 1
+ epoch = 1
url = http://www.wingware.com
install = wingide.install
arch = i686
@@ -15,14 +16,14 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source_i686 = http://wingware.com/pub/wingide/5.1.8/wingide-5.1.8-1-i386-linux.tar.gz
- source_i686 = http://wingware.com/pub/wingide/5.1.8/patches/fix-run-as-pkg-module-5.1.8p1-all.tar
- md5sums_i686 = a8960c2099f86e4385985e49ca05dfcf
- md5sums_i686 = 377ca1633a9bbfaf46dda934ea52a8f5
- source_x86_64 = http://wingware.com/pub/wingide/5.1.8/wingide-5.1.8-1-x86_64-linux.tar.gz
- source_x86_64 = http://wingware.com/pub/wingide/5.1.8/patches/fix-run-as-pkg-module-5.1.8p1-all.tar
- md5sums_x86_64 = 7038e5dc3e73fe30aa1098622a1a3616
- md5sums_x86_64 = 377ca1633a9bbfaf46dda934ea52a8f5
+ source_i686 = http://wingware.com/pub/wingide/5.1.9/wingide-5.1.9-1-i386-linux.tar.gz
+ source_i686 = http://wingware.com/pub/wingide/5.1.9/patches/completer-fix-5.1.9p1-all.tar
+ md5sums_i686 = faa0e3886822334aa915fee36b8b6392
+ md5sums_i686 = 4715939cdbf494f4993b5e97ffacda55
+ source_x86_64 = http://wingware.com/pub/wingide/5.1.9/wingide-5.1.9-1-x86_64-linux.tar.gz
+ source_x86_64 = http://wingware.com/pub/wingide/5.1.9/patches/completer-fix-5.1.9p1-all.tar
+ md5sums_x86_64 = c02ef6cecd3394ed14947c49176b8fb1
+ md5sums_x86_64 = 4715939cdbf494f4993b5e97ffacda55
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index f19deda37d27..3c12f7e99123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=5.1.8
+_wingver=5.1.9
_wingrel=1
pkgver=$_wingver.$_wingrel
pkgrel=1
+epoch=1 #bump this when adding a new patch
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('i686' 'x86_64')
[ "$CARCH" = 'i686' ] && _pkgarch=i386
[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-_wingpatch_x86_64=("fix-run-as-pkg-module-5.1.8p1-all.tar")
-_wingpatch_i686=("fix-run-as-pkg-module-5.1.8p1-all.tar")
+_wingpatch_x86_64=("completer-fix-5.1.9p1-all.tar")
+_wingpatch_i686=("completer-fix-5.1.9p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
if [[ ! -z "$_wingpatch_x86_64" ]]; then
_wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
@@ -24,10 +25,10 @@ source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_
source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" $_wingpatch_i686)
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('a8960c2099f86e4385985e49ca05dfcf'
- '377ca1633a9bbfaf46dda934ea52a8f5')
-md5sums_x86_64=('7038e5dc3e73fe30aa1098622a1a3616'
- '377ca1633a9bbfaf46dda934ea52a8f5')
+md5sums_i686=('faa0e3886822334aa915fee36b8b6392'
+ '4715939cdbf494f4993b5e97ffacda55')
+md5sums_x86_64=('c02ef6cecd3394ed14947c49176b8fb1'
+ '4715939cdbf494f4993b5e97ffacda55')
install=${pkgname}.install
prepare() {