summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-01-23 16:40:18 +0000
committerGrey Christoforo2019-01-23 16:40:18 +0000
commita1452b9ed153f7177c77467b659241994c13bce3 (patch)
tree0ccdbd2204204af6c312689aa8c1bf40068165f5
parentfa9e520cfa25d84e6b6cbd1f6ef8a673bc82ef35 (diff)
downloadaur-a1452b9ed153f7177c77467b659241994c13bce3.tar.gz
version bump
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54da324b4eac..a04811dd47b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.1.2.1.3
+ pkgver = 6.1.4.1.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -12,18 +12,10 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.1.2/wingide-6.1.2-1-x86_64-linux.tar.bz2
- source = http://wingware.com/pub/wingide/6.1.2/patches/fix-new-venv-6.1.2p1-all.tar
- source = http://wingware.com/pub/wingide/6.1.2/patches/fix-goto-defn-6.1.2p4-all.tar
- source = http://wingware.com/pub/wingide/6.1.2/patches/fix-activation-6.1.2p2-all.tar
- source = http://wingware.com/pub/wingide/6.1.2/patches/fix-sassist-links-6.1.2p6-all.tar
- source = http://wingware.com/pub/wingide/6.1.2/patches/fix-autocomplete-lockup-6.1.2p7-all.tar
- md5sums = c64255d62885498ac20513cafd7527c3
- md5sums = cf1a2166c7a3605264d22269b346fb7d
- md5sums = d691d2b46be9d0723b2c9742b89f9506
- md5sums = 67f6cf80f5b8031a6ace081b38e28286
- md5sums = 2e337be8917cbd6d7692f974c95888ad
- md5sums = 67926f2b3ad03cde727f66078455e8b7
+ source = http://wingware.com/pub/wingide/6.1.4/wingide-6.1.4-1-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.1.4/patches/fix-find-symbol-6.1.4p1-all.tar
+ md5sums = 1a0007a298152cb8a9454534c6af21c9
+ md5sums = 0425c50fecff2fdfa1e41addc13ce825
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 486340daa65f..b8eb0793ba34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.1.2
+_wingver=6.1.4
_wingrel=1
-_wing_patch_lvl=3 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-
-_wingpatch=("fix-new-venv-6.1.2p1-all.tar" "fix-goto-defn-6.1.2p4-all.tar" "fix-activation-6.1.2p2-all.tar" "fix-sassist-links-6.1.2p6-all.tar" "fix-autocomplete-lockup-6.1.2p7-all.tar")
+_wingpatch=("fix-find-symbol-6.1.4p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('c64255d62885498ac20513cafd7527c3'
- 'cf1a2166c7a3605264d22269b346fb7d'
- 'd691d2b46be9d0723b2c9742b89f9506'
- '67f6cf80f5b8031a6ace081b38e28286'
- '2e337be8917cbd6d7692f974c95888ad'
- '67926f2b3ad03cde727f66078455e8b7')
+md5sums=('1a0007a298152cb8a9454534c6af21c9'
+ '0425c50fecff2fdfa1e41addc13ce825')
install=${pkgname}.install