summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-05-22 15:37:20 +0100
committerGrey Christoforo2018-05-22 15:37:20 +0100
commitdbf78d4475d716a668686d3b44596722300e3549 (patch)
treec3e3c2a48fcd9395bb17248dace2e43f831cf3dd
parentff8ae0ea14b3fde9c3a04b1004b551ef33344fd4 (diff)
downloadaur-dbf78d4475d716a668686d3b44596722300e3549.tar.gz
add patches
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f6b79ca61d..fb5bc37e58c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.0.12.1.1
+ pkgver = 6.0.12.1.2
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -13,7 +13,15 @@ pkgbase = wingide
options = !strip
options = !emptydirs
source = http://wingware.com/pub/wingide/6.0.12/wingide-6.0.12-1-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.0.12/patches/fix-remotely-stored-projects-6.0.12p1-all.tar
+ source = http://wingware.com/pub/wingide/6.0.12/patches/fix-vi-visual-bc-6.0.12p2-all.tar
+ source = http://wingware.com/pub/wingide/6.0.12/patches/fix-matplotlib-debug-6.0.12p3-all.tar
+ source = http://wingware.com/pub/wingide/6.0.12/patches/fix-logging-exc-6.0.12p4-all.tar
md5sums = 74a72215aa827fe19049bea5d24382cc
+ md5sums = 8ab32b0c575907db9603e6ed52b4fe69
+ md5sums = caef531adab241abc9349259a82a5cf6
+ md5sums = 1bd037a9f2b4b1ce3fc9d3a2e1c3213a
+ md5sums = 3dd2a8fbec556973b2b432a085f2bb7d
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index c190146e7cbf..67199785108e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
pkgname=wingide
_wingver=6.0.12
_wingrel=1
-_wing_patch_lvl=1 #bump this when adding a patch
+_wing_patch_lvl=2 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-#_wingpatch=("fix-remote-projects-6.0.11p1-all.tar")
-#_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
-#_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
+
+_wingpatch=("fix-remotely-stored-projects-6.0.12p1-all.tar" "fix-vi-visual-bc-6.0.12p2-all.tar" "fix-matplotlib-debug-6.0.12p3-all.tar" "fix-logging-exc-6.0.12p4-all.tar")
+_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
+_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('74a72215aa827fe19049bea5d24382cc')
+md5sums=('74a72215aa827fe19049bea5d24382cc'
+ '8ab32b0c575907db9603e6ed52b4fe69'
+ 'caef531adab241abc9349259a82a5cf6'
+ '1bd037a9f2b4b1ce3fc9d3a2e1c3213a'
+ '3dd2a8fbec556973b2b432a085f2bb7d')
install=${pkgname}.install