summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-07-21 17:00:40 +0100
committerGrey Christoforo2016-07-21 17:00:40 +0100
commitf9f0a7344a64e4ecd9642c72ad10fc405dbc7a12 (patch)
tree583e695cf4ee5cd92ae523a84791c38601988513
parente970dab7d7a0ddfac7fa5a3c4e0d373baf127be0 (diff)
downloadaur-f9f0a7344a64e4ecd9642c72ad10fc405dbc7a12.tar.gz
add "Ignore invalid window sizes" patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c280e6a71c0..c72c0d071c55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 18 12:31:33 UTC 2016
+# Thu Jul 21 16:00:19 UTC 2016
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 5.1.12.1.1
+ pkgver = 5.1.12.1.2
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -16,9 +16,13 @@ pkgbase = wingide
options = !strip
options = !emptydirs
source_i686 = http://wingware.com/pub/wingide/5.1.12/wingide-5.1.12-1-i386-linux.tar.gz
+ source_i686 = http://wingware.com/pub/wingide/5.1.12/patches/detect-bad-window-sizes-5.1.12p1-all.tar
md5sums_i686 = 6d3e20447ea2b772e4da38bf02c81031
+ md5sums_i686 = 19a4bb32566a523d1acc677c8456c938
source_x86_64 = http://wingware.com/pub/wingide/5.1.12/wingide-5.1.12-1-x86_64-linux.tar.gz
+ source_x86_64 = http://wingware.com/pub/wingide/5.1.12/patches/detect-bad-window-sizes-5.1.12p1-all.tar
md5sums_x86_64 = 52b7f26a71e2a1ea9cbb51ade7181825
+ md5sums_x86_64 = 19a4bb32566a523d1acc677c8456c938
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 712ce29cc443..a8f941ab03e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wingide
_wingver=5.1.12
_wingrel=1
-_wing_patch_lvl=1
+_wing_patch_lvl=2 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
@@ -12,8 +12,8 @@ license=('custom')
arch=('i686' 'x86_64')
[ "$CARCH" = 'i686' ] && _pkgarch=i386
[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-#_wingpatch_x86_64=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
-#_wingpatch_i686=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
+_wingpatch_x86_64=("detect-bad-window-sizes-5.1.12p1-all.tar")
+_wingpatch_i686=("detect-bad-window-sizes-5.1.12p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
if [[ ! -z "$_wingpatch_x86_64" ]]; then
_wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
@@ -25,8 +25,10 @@ source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_
source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" ${_wingpatch_i686[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('6d3e20447ea2b772e4da38bf02c81031')
-md5sums_x86_64=('52b7f26a71e2a1ea9cbb51ade7181825')
+md5sums_i686=('6d3e20447ea2b772e4da38bf02c81031'
+ '19a4bb32566a523d1acc677c8456c938')
+md5sums_x86_64=('52b7f26a71e2a1ea9cbb51ade7181825'
+ '19a4bb32566a523d1acc677c8456c938')
install=${pkgname}.install
prepare() {