summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2016-05-16 10:15:39 +0200
committerMaxime Gauduin2016-05-16 10:15:39 +0200
commit366ed999ab0995702dc81855762d1896f3bf804c (patch)
treeb348365bd17fa13d4c71685faeef09221df5b8d4
parent92639a7d05a220237df146c045d4956eaf58bf7b (diff)
downloadaur-366ed999ab0995702dc81855762d1896f3bf804c.tar.gz
wingpanel-bzr 1:r126-1
Patch isn't needed anymore
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--wingpanel-fixes.patch37
3 files changed, 7 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794715f78219..8a50b7f80f1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon May 16 08:15:38 UTC 2016
pkgbase = wingpanel-bzr
pkgdesc = The Pantheon Panel
- pkgver = r93
+ pkgver = r126
pkgrel = 1
epoch = 1
url = https://launchpad.net/wingpanel
@@ -24,10 +26,8 @@ pkgbase = wingpanel-bzr
provides = wingpanel
provides = libwingpanel-2.0.so
conflicts = wingpanel
- source = wingpanel::bzr+lp:wingpanel/0.4.x
- source = wingpanel-fixes.patch
+ source = wingpanel::bzr+lp:wingpanel
sha256sums = SKIP
- sha256sums = 6f5101f8575a612f8e6c6b21ee9323c82ca1ec5c90fc1abf12a8f29ab2733fd7
pkgname = wingpanel-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 456d67e2c432..a3c710b7d764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: flamelab <panosfilip@gmail.com>
pkgname=wingpanel-bzr
-pkgver=r108
+pkgver=r126
pkgrel=1
epoch=1
pkgdesc='The Pantheon Panel'
@@ -17,10 +17,8 @@ makedepends=('bzr' 'cmake' 'vala')
provides=('wingpanel' 'libwingpanel-2.0.so')
conflicts=('wingpanel')
install='wingpanel.install'
-source=('wingpanel::bzr+lp:wingpanel/0.4.x'
- 'wingpanel-fixes.patch')
-sha256sums=('SKIP'
- '6f5101f8575a612f8e6c6b21ee9323c82ca1ec5c90fc1abf12a8f29ab2733fd7')
+source=('wingpanel::bzr+lp:wingpanel')
+sha256sums=('SKIP')
pkgver() {
cd wingpanel
@@ -31,8 +29,6 @@ pkgver() {
prepare() {
cd wingpanel
- patch -Np1 -i ../wingpanel-fixes.patch
-
if [[ -d build ]]; then
rm -rf build
fi
diff --git a/wingpanel-fixes.patch b/wingpanel-fixes.patch
deleted file mode 100644
index 584cc4f28ecf..000000000000
--- a/wingpanel-fixes.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -rupN wingpanel-rewrite-x11.orig/vapi/xfixes-4.0.vapi wingpanel-rewrite-x11/vapi/xfixes-4.0.vapi
---- wingpanel-rewrite-x11.orig/vapi/xfixes-4.0.vapi 1970-01-01 01:00:00.000000000 +0100
-+++ wingpanel-rewrite-x11/vapi/xfixes-4.0.vapi 2015-06-04 15:31:20.177646063 +0200
-@@ -0,0 +1,24 @@
-+/* xfixes-4.0.vapi generated by vapigen, do not modify. */
-+/* Manually edited, so feel free to add and adjust it directly */
-+
-+[CCode (cprefix = "X", gir_namespace = "xfixes", gir_version = "4.0", lower_case_cprefix = "X_")]
-+namespace X {
-+ namespace Fixes {
-+ [CCode (cheader_filename = "X11/extensions/Xfixes.h", cname = "XFixesCreateRegion")]
-+ public static X.XserverRegion create_region (X.Display display, [CCode (array_length = true)] X.Xrectangle[] rectangles);
-+ [CCode (cheader_filename = "X11/extensions/Xfixes.h", cname = "XFixesDestroyRegion")]
-+ public static void destroy_region (X.Display display, X.XserverRegion region);
-+ }
-+ [SimpleType]
-+ [CCode (cheader_filename = "X11/extensions/Xfixes.h", cname = "XserverRegion", has_type_id = false)]
-+ public struct XserverRegion {
-+ }
-+ [SimpleType]
-+ [CCode (cheader_filename = "X11/Xlib.h", cname = "XRectangle", has_type_id = false)]
-+ public struct Xrectangle {
-+ public short x;
-+ public short y;
-+ public ushort width;
-+ public ushort height;
-+ }
-+}
-diff -rupN wingpanel-rewrite-x11.orig/wingpanel-interface/CMakeLists.txt wingpanel-rewrite-x11/wingpanel-interface/CMakeLists.txt
---- wingpanel-rewrite-x11.orig/wingpanel-interface/CMakeLists.txt 2015-06-04 15:30:20.002739439 +0200
-+++ wingpanel-rewrite-x11/wingpanel-interface/CMakeLists.txt 2015-06-04 15:31:35.983849788 +0200
-@@ -30,4 +30,4 @@ OPTIONS
- add_library (${WINGPANELINTERFACE} MODULE ${VALA_C})
- target_link_libraries(${WINGPANELINTERFACE} ${DEPS_LIBRARIES})
-
--install (TARGETS ${WINGPANELINTERFACE} DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/x86_64-linux-gnu/gala/plugins")
-+install (TARGETS ${WINGPANELINTERFACE} DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/gala/plugins")