summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 17:37:19 +0200
committerMaxime Gauduin2017-05-01 17:37:19 +0200
commit000606aa6a763f7baa8489a8b079bfeb60306dbd (patch)
tree710f0e17cab7c48a66f7ded726730ef673268942
downloadaur-000606aa6a763f7baa8489a8b079bfeb60306dbd.tar.gz
Add wingpanel-indicator-a11y
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD51
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b118d6369199
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Mon May 1 15:37:19 UTC 2017
+pkgbase = wingpanel-indicator-a11y-git
+ pkgdesc = Universal Access indicator for Wingpanel
+ pkgver = r6.50f0e85
+ pkgrel = 1
+ url = https://github.com/elementary/wingpanel-indicator-a11y
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = vala
+ makedepends = wingpanel-git
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgranite.so
+ depends = libwingpanel-2.0.so
+ provides = wingpanel-indicator-a11y
+ conflicts = wingpanel-indicator-a11y
+ replaces = wingpanel-indicator-a11y-bzr
+ source = git+https://github.com/elementary/wingpanel-indicator-a11y.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-a11y-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6da09bf70259
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-a11y-git
+pkgver=r6.50f0e85
+pkgrel=1
+pkgdesc='Universal Access indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/wingpanel-indicator-a11y'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3'
+ 'libgranite.so' 'libwingpanel-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'vala' 'wingpanel-git')
+provides=('wingpanel-indicator-a11y')
+conflicts=('wingpanel-indicator-a11y')
+replaces=('wingpanel-indicator-a11y-bzr')
+source=('git+https://github.com/elementary/wingpanel-indicator-a11y.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel-indicator-a11y
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd wingpanel-indicator-a11y
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-a11y/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-a11y/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: