summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2016-08-21 10:46:21 +0200
committerMaxime Gauduin2016-08-21 10:46:21 +0200
commitae516d84a6f536a65cfcecf7bde690be4b054140 (patch)
tree41dbc650cf57eeb742d358ccc3b768c2ec0ea08a
downloadaur-ae516d84a6f536a65cfcecf7bde690be4b054140.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD42
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e2c8965ca87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Sun Aug 21 08:46:21 UTC 2016
+pkgbase = wingpanel-indicator-ayatana
+ pkgdesc = Ayatana indicator for Wingpanel
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://launchpad.net/wingpanel-indicator-ayatana
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libindicator-gtk3
+ depends = libwingpanel-2.0.so
+ source = https://launchpad.net/wingpanel-indicator-ayatana/loki/2.0.1/+download/wingpanel-indicator-ayatana-2.0.1.tar.xz
+ sha256sums = df266b9b9781387ef609e4c3ad9c5b8faa8479ec438d95613be314e6018f6aae
+
+pkgname = wingpanel-indicator-ayatana
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..a0f490eded61
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('wingpanel-indicator-ayatana')
+builddeps=('libindicator-gtk3' 'gala-bzr' 'wingpanel')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..895cc4821397
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-ayatana
+pkgver=2.0.1
+pkgrel=1
+pkgdesc='Ayatana indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/wingpanel-indicator-ayatana'
+license=('GPL3')
+groups=('pantheon')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee' 'libindicator-gtk3'
+ 'libwingpanel-2.0.so')
+makedepends=('cmake' 'vala')
+source=("https://launchpad.net/wingpanel-indicator-ayatana/loki/${pkgver}/+download/wingpanel-indicator-ayatana-${pkgver}.tar.xz")
+sha256sums=('df266b9b9781387ef609e4c3ad9c5b8faa8479ec438d95613be314e6018f6aae')
+
+prepare() {
+ cd wingpanel-indicator-ayatana-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-ayatana-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-ayatana-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: