summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-28 12:18:48 +0200
committerMaxime Gauduin2017-05-28 12:18:48 +0200
commitd6133848f9039483a0f61798a5ee12acbe01cd24 (patch)
treeabb155f5f91d4aed3b351affce05dec239f950be
downloadaur-d6133848f9039483a0f61798a5ee12acbe01cd24.tar.gz
Add wingpanel-indicator-ayatana-git
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD51
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2381238a3c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Sun May 28 10:18:48 UTC 2017
+pkgbase = wingpanel-indicator-ayatana-git
+ pkgdesc = Wingpanel Ayatana-Compatibility Indicator
+ pkgver = r36.8533b03
+ pkgrel = 1
+ url = https://github.com/elementary/wingpanel-indicator-ayatana
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libindicator-gtk3-ubuntu
+ depends = libwingpanel-2.0.so
+ provides = wingpanel-indicator-ayatana
+ conflicts = wingpanel-indicator-ayatana
+ replaces = wingpanel-indicator-ayatana-bzr
+ source = git+https://github.com/elementary/wingpanel-indicator-ayatana.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-ayatana-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d03b5667c7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-ayatana-git
+pkgver=r36.8533b03
+pkgrel=1
+pkgdesc='Wingpanel Ayatana-Compatibility Indicator'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/wingpanel-indicator-ayatana'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee' 'libindicator-gtk3-ubuntu'
+ 'libwingpanel-2.0.so')
+makedepends=('cmake' 'git' 'gobject-introspection' 'vala')
+provides=('wingpanel-indicator-ayatana')
+conflicts=('wingpanel-indicator-ayatana')
+replaces=('wingpanel-indicator-ayatana-bzr')
+source=('git+https://github.com/elementary/wingpanel-indicator-ayatana.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel-indicator-ayatana
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd wingpanel-indicator-ayatana
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-ayatana/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-ayatana/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: