summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2016-08-16 21:07:08 +0200
committerMaxime Gauduin2016-08-16 21:08:41 +0200
commit83f390fc71efd43468b2af219ccab89e3039be73 (patch)
treee534fe31b60be09bb10a7c7a52bbbc0d74cd8423
downloadaur-83f390fc71efd43468b2af219ccab89e3039be73.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD43
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3afe9aaa0523
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Aug 16 19:07:08 UTC 2016
+pkgbase = wingpanel-indicator-bluetooth
+ pkgdesc = Bluetooth indicator for Wingpanel
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://launchpad.net/wingpanel-indicator-bluetooth
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = bluez
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgranite.so
+ depends = libwingpanel-2.0.so
+ source = https://launchpad.net/wingpanel-indicator-bluetooth/loki/2.0/+download/wingpanel-indicator-bluetooth-2.0.tar.xz
+ sha256sums = 8d35b8604e0d397e3b6c9316764c83a1d17340aeb878011195e7e67350e3069d
+
+pkgname = wingpanel-indicator-bluetooth
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..3e20cc3d9aeb
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('wingpanel-indicator-bluetooth')
+builddeps=('gala-bzr' 'wingpanel')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4207df3133b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-bluetooth
+pkgver=2.0
+pkgrel=1
+pkgdesc='Bluetooth indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/wingpanel-indicator-bluetooth'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('bluez' 'glib2' 'glibc' 'gtk3'
+ 'libgranite.so' 'libwingpanel-2.0.so')
+makedepends=('bzr' 'cmake' 'vala')
+source=("https://launchpad.net/wingpanel-indicator-bluetooth/loki/${pkgver}/+download/wingpanel-indicator-bluetooth-${pkgver}.tar.xz")
+sha256sums=('8d35b8604e0d397e3b6c9316764c83a1d17340aeb878011195e7e67350e3069d')
+
+prepare() {
+ cd wingpanel-indicator-bluetooth-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-bluetooth-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='FALSE'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-bluetooth-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: