summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 18:18:53 +0200
committerMaxime Gauduin2017-05-01 18:18:53 +0200
commit6fb4d0c0a5a64b9178d6522d535b6b6abf55cc7e (patch)
treeaec92925f5ad30c9128a5a2ce7c566fcac116d90
downloadaur-6fb4d0c0a5a64b9178d6522d535b6b6abf55cc7e.tar.gz
Add wingpanel-indicator-bluetooth-git
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD51
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..221e795a03bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon May 1 16:18:53 UTC 2017
+pkgbase = wingpanel-indicator-bluetooth-git
+ pkgdesc = Bluetooth indicator for Wingpanel
+ pkgver = r111.0c3df8d
+ pkgrel = 1
+ url = https://github.com/elementary/wingpanel-indicator-bluetooth
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = intltool
+ makedepends = vala
+ makedepends = wingpanel-git
+ depends = bluez
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libwingpanel-2.0.so
+ provides = wingpanel-indicator-bluetooth
+ conflicts = wingpanel-indicator-bluetooth
+ source = git+https://github.com/elementary/wingpanel-indicator-bluetooth.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-bluetooth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4810b1f7d8a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-bluetooth-git
+pkgver=r111.0c3df8d
+pkgrel=1
+pkgdesc='Bluetooth indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/wingpanel-indicator-bluetooth'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('bluez' 'glib2' 'glibc' 'gtk3' 'libgee'
+ 'libwingpanel-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'intltool' 'vala' 'wingpanel-git')
+provides=('wingpanel-indicator-bluetooth')
+conflicts=('wingpanel-indicator-bluetooth')
+source=('git+https://github.com/elementary/wingpanel-indicator-bluetooth.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel-indicator-bluetooth
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd wingpanel-indicator-bluetooth
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-bluetooth/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='OFF'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-bluetooth/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: