summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2019-02-03 05:33:02 +0900
committerQue Quotion2019-02-03 05:33:02 +0900
commit27c7213d93d0fddac33f8f126d2b094f1b67d9ea (patch)
tree392c2ab93d836cf55fd916322e0bd9582c65818d
downloadaur-27c7213d93d0fddac33f8f126d2b094f1b67d9ea.tar.gz
Initial commit; unofficial replacement for wingpanel-indicator-ayatana (keeps all ayatana indicators under a single indicator)
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acc936bce453
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = wingpanel-indicator-namarupa-git
+ pkgdesc = Unofficial Ayatana compatibility layer for wingpanel
+ pkgver = r11.c168028
+ pkgrel = 1
+ url = https://github.com/donadigo/wingpanel-indicator-namarupa
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = granite
+ depends = libindicator-gtk3-ubuntu
+ depends = libwingpanel-2.0.so
+ conflicts = wingpanel-indicator-ayatana
+ source = git+https://github.com/donadigo/wingpanel-indicator-namarupa.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-namarupa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7a05b1437ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-namarupa-git
+pkgver=r11.c168028
+pkgrel=1
+pkgdesc='Unofficial Ayatana compatibility layer for wingpanel'
+arch=('i686' 'x86_64')
+url='https://github.com/donadigo/wingpanel-indicator-namarupa'
+license=('GPL3')
+#depends=('gdk-pixbuf2' 'libgee' #guilty of these dependencies until proven otherwise, but not listed upstream
+depends=('glib2' 'glibc' 'gtk3' 'granite'
+ 'libindicator-gtk3-ubuntu'
+ 'libwingpanel-2.0.so')
+makedepends=('meson' 'git' 'gobject-introspection' 'vala')
+conflicts=('wingpanel-indicator-ayatana')
+source=('git+https://github.com/donadigo/wingpanel-indicator-namarupa.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel-indicator-namarupa
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd wingpanel-indicator-namarupa
+ [ -d build ] && rm -rf build
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd wingpanel-indicator-namarupa
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: