summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-04-03 11:27:18 +0200
committerMaxime Gauduin2018-04-03 11:27:18 +0200
commit4b0dc92ae45867a4b07836c767111c0b7b82ab31 (patch)
tree5eb301d0bad0be4d3a116b06f3f8730e16bbbc0f
parent35deaeef0182746969c2ace58b2d8bf80314036e (diff)
downloadaur-4b0dc92ae45867a4b07836c767111c0b7b82ab31.tar.gz
Switch to meson
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fca14e3673cc..d0ba0913e749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Mon May 1 15:59:42 UTC 2017
+# Tue Apr 3 09:27:14 UTC 2018
pkgbase = wingpanel-indicator-notifications-git
pkgdesc = Notifications indicator for Wingpanel
- pkgver = r223.92ffe1a
+ pkgver = r293.ce59ba9
pkgrel = 1
url = https://github.com/elementary/wingpanel-indicator-notifications
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
+ makedepends = meson
makedepends = vala
makedepends = wingpanel-git
depends = glib2
diff --git a/PKGBUILD b/PKGBUILD
index de037f6d492b..11444986336f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-indicator-notifications-git
-pkgver=r223.92ffe1a
+pkgver=r293.ce59ba9
pkgrel=1
pkgdesc='Notifications indicator for Wingpanel'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('glib2' 'glibc' 'gtk3' 'libgee' 'libwnck3'
'libgranite.so' 'libwingpanel-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'vala' 'wingpanel-git')
+makedepends=('git' 'granite-git' 'meson' 'vala' 'wingpanel-git')
provides=('wingpanel-indicator-notifications')
conflicts=('wingpanel-indicator-notifications')
source=('git+https://github.com/elementary/wingpanel-indicator-notifications.git')
@@ -23,8 +23,6 @@ pkgver() {
}
prepare() {
- cd wingpanel-indicator-notifications
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -32,20 +30,16 @@ prepare() {
}
build() {
- cd wingpanel-indicator-notifications/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='OFF'
- make
+ cd build
+
+ arch-meson ../wingpanel-indicator-notifications
+ ninja
}
package() {
- cd wingpanel-indicator-notifications/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: