summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2019-04-03 17:22:09 +0900
committerQue Quotion2019-04-03 17:22:09 +0900
commit00393eb32c49ae2ccc2ab9ad65e76245e1a5e941 (patch)
tree7dfa565bdaf6e98b0162d2a152cb8cfaefc7c1b2
downloadaur-00393eb32c49ae2ccc2ab9ad65e76245e1a5e941.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f75576420e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = wingpanel-indicator-sensors-git
+ pkgdesc = Sensors indicator for Wingpanel
+ pkgver = r5.0c29892
+ pkgrel = 1
+ url = https://github.com/Dirli/wingpanel-indicator-sensors
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL2
+ makedepends = git
+ makedepends = granite
+ makedepends = meson
+ makedepends = vala
+ makedepends = libwingpanel-2.0.so
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = granite
+ depends = libgee
+ depends = libwingpanel-2.0.so
+ provides = wingpanel-indicator-sensors
+ conflicts = wingpanel-indicator-sensors
+ source = git+https://github.com/Dirli/wingpanel-indicator-sensors.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-sensors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ad93d860d8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Que Quotion <quequotion@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-sensors-git
+pkgver=r5.0c29892
+pkgrel=1
+pkgdesc='Sensors indicator for Wingpanel'
+arch=('x86_64')
+url='https://github.com/Dirli/wingpanel-indicator-sensors'
+license=('GPL2')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'granite' 'libgee' 'libwingpanel-2.0.so')
+makedepends=('git' 'granite' 'meson' 'vala' 'libwingpanel-2.0.so')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/Dirli/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ [ -d build ] && rm -rf build
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname%-git}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}