summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-04-03 11:30:38 +0200
committerMaxime Gauduin2018-04-03 11:30:38 +0200
commit03591cc745eca5bf4bdb0fcd53eaa98ff666633f (patch)
tree68206135bcc022945775eda5e178a96ee9e7da74
parentc9875c917747d4e2738f13b7b82605dcc475ae67 (diff)
downloadaur-03591cc745eca5bf4bdb0fcd53eaa98ff666633f.tar.gz
Switch to meson
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b73ce3ea92c9..e60ad8c7f9e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Mon May 1 17:23:24 UTC 2017
+# Tue Apr 3 09:30:33 UTC 2018
pkgbase = wingpanel-indicator-session-git
pkgdesc = Session indicator for Wingpanel
- pkgver = r204.2c0d101
+ pkgver = r292.1ae5d21
pkgrel = 1
url = https://github.com/elementary/wingpanel-indicator-session
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL2
- makedepends = cmake
makedepends = git
makedepends = gobject-introspection
makedepends = granite-git
+ makedepends = meson
makedepends = vala
makedepends = wingpanel-git
depends = accountsservice
@@ -24,7 +23,6 @@ pkgbase = wingpanel-indicator-session-git
depends = libwingpanel-2.0.so
provides = wingpanel-indicator-session
conflicts = wingpanel-indicator-session
- replaces = wingpanel-indicator-session-bzr
source = git+https://github.com/elementary/wingpanel-indicator-session.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 589c5eedf253..11163abdffd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-indicator-session-git
-pkgver=r204.2c0d101
+pkgver=r292.1ae5d21
pkgrel=1
pkgdesc='Session indicator for Wingpanel'
arch=('x86_64')
@@ -10,11 +10,10 @@ license=('GPL2')
groups=('pantheon-unstable')
depends=('accountsservice' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3'
'libgranite.so' 'libwingpanel-2.0.so')
-makedepends=('cmake' 'git' 'gobject-introspection' 'granite-git' 'vala'
+makedepends=('git' 'gobject-introspection' 'granite-git' 'meson' 'vala'
'wingpanel-git')
provides=('wingpanel-indicator-session')
conflicts=('wingpanel-indicator-session')
-replaces=('wingpanel-indicator-session-bzr')
source=('git+https://github.com/elementary/wingpanel-indicator-session.git')
sha256sums=('SKIP')
@@ -25,8 +24,6 @@ pkgver() {
}
prepare() {
- cd wingpanel-indicator-session
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -34,19 +31,16 @@ prepare() {
}
build() {
- cd wingpanel-indicator-session/build
+ cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib'
- make
+ arch-meson ../wingpanel-indicator-session
+ ninja
}
package() {
- cd wingpanel-indicator-session/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: