summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2019-03-08 19:18:12 +0900
committerQue Quotion2019-03-08 19:18:12 +0900
commit14e25b6687a1bdf08fda0c9aff1e85f929931806 (patch)
treeea99085a751a8dbcc511ec7936b9e6a8cc69329f
parent8a11169b5689ce5c0be95de3fbc52d6f1d2d0cc2 (diff)
downloadaur-14e25b6687a1bdf08fda0c9aff1e85f929931806.tar.gz
There is no longer a problem finding cogl; probably ever since switching to meson.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--y-is-broken-cogl.patch10
3 files changed, 4 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d91203cad485..ed2a140c1a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
- pkgver = r382.dd64ba8
+ pkgver = r387.fc1b8ea
pkgrel = 1
url = https://github.com/elementary/wingpanel
arch = i686
@@ -11,6 +11,7 @@ pkgbase = wingpanel-standalone-git
makedepends = git
makedepends = granite-git
makedepends = vala
+ makedepends = cogl
depends = glib2
depends = glibc
depends = gtk3
@@ -43,7 +44,6 @@ pkgbase = wingpanel-standalone-git
source = minus-backgroundmanager.patch
source = minus-galaplugin.patch
source = minus-gala.patch
- source = y-is-broken-cogl.patch
source = autohide.patch
source = reverse-105c1d0.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8bd2a2a165d8..728c2345752e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-standalone-git
-pkgver=r382.dd64ba8
+pkgver=r387.fc1b8ea
pkgrel=1
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('GPL3')
groups=('pantheon-qq')
depends=('glib2' 'glibc' 'gtk3' 'libgee'
'libgranite.so' 'libwnck3')
-makedepends=('cmake' 'git' 'granite-git' 'vala')
+makedepends=('cmake' 'git' 'granite-git' 'vala' 'cogl')
optdepends=("pantheon-applications-menu-git: Application launcher"
wingpanel-indicator-{a11y,bluetooth,datetime,keyboard,network,notifications,power,session,sound}-git": Tray applet"
"wingpanel-indicator-ayatana-git: Unity 7 Tray applets"
@@ -26,7 +26,6 @@ source=('git+https://github.com/elementary/wingpanel.git'
'minus-backgroundmanager.patch'
'minus-galaplugin.patch'
'minus-gala.patch'
- 'y-is-broken-cogl.patch'
'autohide.patch'
'reverse-105c1d0.patch')
sha256sums=('SKIP'
@@ -63,10 +62,6 @@ prepare() {
patch -Np2 < ../minus-galaplugin.patch
patch -Np2 < ../minus-gala.patch
- #Cogl can't be found when not using gala's cmake package; wtf?
- msg2 "Remove CoglFixes (broken)"
- patch -Np2 < ../y-is-broken-cogl.patch
-
[ ! -d build ] || rm -rf build
}
diff --git a/y-is-broken-cogl.patch b/y-is-broken-cogl.patch
deleted file mode 100644
index 76fb21017e5a..000000000000
--- a/y-is-broken-cogl.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/wingpanel/vapi/cogl-fixes.vapi 2017-05-13 02:46:33.880734704 +0900
-+++ /dev/null 2017-05-12 04:15:23.019728097 +0900
-@@ -1,6 +0,0 @@
--namespace CoglFixes
--{
-- [CCode (cname = "cogl_texture_get_data")]
-- public int texture_get_data (Cogl.Texture texture, Cogl.PixelFormat format, uint rowstride, [CCode (array_length = false)] uint8[] pixels);
--}
--
-