summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-06-01 01:42:44 +0900
committerQue Quotion2017-06-01 01:42:44 +0900
commit8e7729d1d63bdec0acbddedddcd94c974074006b (patch)
treecc411fd4ca115cf6e15b7092e78e2fb2573ceb3f
parentb099aaecd33abf81db21456271e5a7137cdd05be (diff)
downloadaur-8e7729d1d63bdec0acbddedddcd94c974074006b.tar.gz
autohide is ready to ship!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--autohide-evbox.patch2
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b42f82865ad..92efc1043002 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed May 31 16:24:36 UTC 2017
+# Wed May 31 16:42:18 UTC 2017
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
pkgver = r288.0b6d486
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/elementary/wingpanel
arch = i686
arch = x86_64
@@ -53,7 +53,7 @@ pkgbase = wingpanel-standalone-git
sha256sums = 1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95
sha256sums = 910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d
sha256sums = df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced
- sha256sums = 9fb6f2657692d68228130ed8c8480a5ee66fe473112a37679885ae343b824fb8
+ sha256sums = 7cf4d73688e7edc258a9ed2803fa018250a9ec3307b4d1399298d567459fb87a
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index 8b554ce0196c..27e331abed32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wingpanel-standalone-git
pkgver=r288.0b6d486
-pkgrel=1
+pkgrel=2
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
url='https://github.com/elementary/wingpanel'
@@ -33,7 +33,7 @@ sha256sums=('SKIP'
'1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95'
'910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d'
'df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced'
- '9fb6f2657692d68228130ed8c8480a5ee66fe473112a37679885ae343b824fb8')
+ '7cf4d73688e7edc258a9ed2803fa018250a9ec3307b4d1399298d567459fb87a')
pkgver() {
cd wingpanel
@@ -58,10 +58,10 @@ prepare() {
patch -Np2 < ../minus-gala-cmake.patch
#autohide
- #msg2 "autohide"
- #patch -Np2 < ../autohide-evbox.patch
+ msg2 "autohide"
+ patch -Np2 < ../autohide-evbox.patch
- #Cogl can't be found, although it is installed. Arch-specific? .so bump?
+ #Cogl can't be found when not using gala's cmake package; wtf?
msg2 "minus cgl"
patch -Np2 < ../y-is-broken-cogl.patch
}
diff --git a/autohide-evbox.patch b/autohide-evbox.patch
index 1f0c35fb6e4f..cf8d65dc02c0 100644
--- a/autohide-evbox.patch
+++ b/autohide-evbox.patch
@@ -56,7 +56,7 @@
//Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
- Timeout.add (300 / panel_height, animation_step);
-+ Timeout.add (100 / panel_height, animation_step);
++ timeout = Timeout.add (100 / panel_height, animation_step);
+ }
+
+ private bool on_idle () {