summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-06-01 01:26:19 +0900
committerQue Quotion2017-06-01 01:26:19 +0900
commitb099aaecd33abf81db21456271e5a7137cdd05be (patch)
treefd6c30f822bc362923d28054f4f9248a6a873fa4
parentfef272949a939d16eb64d7b69e203d22148dde7d (diff)
downloadaur-b099aaecd33abf81db21456271e5a7137cdd05be.tar.gz
kill timers to fix infinite loops!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--autohide-evbox.patch18
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1488b3e8fb4..3b42f82865ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed May 31 13:43:33 UTC 2017
+# Wed May 31 16:24:36 UTC 2017
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
pkgver = r288.0b6d486
@@ -53,7 +53,7 @@ pkgbase = wingpanel-standalone-git
sha256sums = 1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95
sha256sums = 910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d
sha256sums = df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced
- sha256sums = 67b4b3a2bbdb9c7b737f6380a876a8f4083217704247c6b4176ae2055911ec2c
+ sha256sums = 9fb6f2657692d68228130ed8c8480a5ee66fe473112a37679885ae343b824fb8
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index 2ab22d91f47b..8b554ce0196c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,7 +33,7 @@ sha256sums=('SKIP'
'1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95'
'910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d'
'df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced'
- '67b4b3a2bbdb9c7b737f6380a876a8f4083217704247c6b4176ae2055911ec2c')
+ '9fb6f2657692d68228130ed8c8480a5ee66fe473112a37679885ae343b824fb8')
pkgver() {
cd wingpanel
diff --git a/autohide-evbox.patch b/autohide-evbox.patch
index 7a862a20a4a9..1f0c35fb6e4f 100644
--- a/autohide-evbox.patch
+++ b/autohide-evbox.patch
@@ -1,11 +1,13 @@
--- src/wingpanel/src/PanelWindow.vala.old 2017-05-30 05:11:04.862053641 +0900
+++ src/wingpanel/src/PanelWindow.vala 2017-05-30 05:15:50.025099860 +0900
-@@ -22,6 +22,8 @@
+@@ -22,6 +22,10 @@
private Widgets.Panel panel;
+ private Gtk.EventBox box;
+
++ uint timeout;
++
private int monitor_number;
private int monitor_width;
@@ -49,7 +51,7 @@
return true;
}
-@@ -85,7 +106,23 @@
+@@ -85,7 +106,27 @@
//Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
@@ -58,17 +60,21 @@
+ }
+
+ private bool on_idle () {
-+ animate_panel ();
++ if (timeout > 0) {
++ Source.remove (timeout);
++ }
+
-+ Timeout.add (100 / panel_height, animation_unstep);
++ timeout = Timeout.add (100 / panel_height, animation_unstep);
+
+ return true;
+ }
+
+ private bool reactivate () {
-+ animate_panel ();
++ if (timeout > 0) {
++ Source.remove (timeout);
++ }
+
-+ Timeout.add (100 / panel_height, animation_step);
++ timeout = Timeout.add (100 / panel_height, animation_step);
+
+ return true;
}