summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2018-09-17 22:12:13 +0900
committerQue Quotion2018-09-17 22:12:24 +0900
commiteb9009776fc9ee0575cf1a1370d2bcbdbbb2649b (patch)
tree03de12e591e269d1203ef2b1749854f23d824da5
parent3de9564dee82434fd6bc59e724ecfd03942c0206 (diff)
downloadaur-eb9009776fc9ee0575cf1a1370d2bcbdbbb2649b.tar.gz
Fixes for libwnck dependency; restore original animation speed for "Disabled"
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--autohide.patch28
-rw-r--r--minus-gala.patch4
4 files changed, 30 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa733397cd..2322ef85ed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -50,9 +50,9 @@ pkgbase = wingpanel-standalone-git
sha256sums = SKIP
sha256sums = 67ffdac17cd4f46fb866eb8d33dd06db918bca16ae8ed4b2a2a00c3112f87a2b
sha256sums = 7f972d79b4d72f7b274a96e1a5150cba0e3869ad85215ae01ad2bc19802cdbb9
- sha256sums = 21e95aec3fbb920f3b8ef34b00bf4fc99f431e1837f84f020d5d00c4e3aaca0b
+ sha256sums = 20ec1d51a6610bf0105c772e4d1d4ac8f35ea0ee33b066981db57dc19fe3bdc6
sha256sums = b1902c1d44ac546df63cd0224a7d2ef2cb6394ca556512c30c370d387db7bbab
- sha256sums = 244b035630316c1f1a091dde16936f411600fdc68bd0dab9735f335fce3eeccc
+ sha256sums = d14dcf9e151f3cf920ea589c4fc935387ce74b83c5c72c162911516a62b4c5eb
sha256sums = 53bfa2220d14065ca848c36217abe812685c7d6e0d42251423d0faa2a0ac5394
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index e17014e609c..46bed7f49e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,9 +32,9 @@ source=('git+https://github.com/elementary/wingpanel.git'
sha256sums=('SKIP'
'67ffdac17cd4f46fb866eb8d33dd06db918bca16ae8ed4b2a2a00c3112f87a2b'
'7f972d79b4d72f7b274a96e1a5150cba0e3869ad85215ae01ad2bc19802cdbb9'
- '21e95aec3fbb920f3b8ef34b00bf4fc99f431e1837f84f020d5d00c4e3aaca0b'
+ '20ec1d51a6610bf0105c772e4d1d4ac8f35ea0ee33b066981db57dc19fe3bdc6'
'b1902c1d44ac546df63cd0224a7d2ef2cb6394ca556512c30c370d387db7bbab'
- '244b035630316c1f1a091dde16936f411600fdc68bd0dab9735f335fce3eeccc'
+ 'd14dcf9e151f3cf920ea589c4fc935387ce74b83c5c72c162911516a62b4c5eb'
'53bfa2220d14065ca848c36217abe812685c7d6e0d42251423d0faa2a0ac5394')
pkgver() {
@@ -52,7 +52,7 @@ prepare() {
#Autohide
msg2 "Autohide"
- patch -Np2 < ../autohide-dodge.patch
+ patch -Np2 < ../autohide.patch
#patch -Np2 < ../autohide-testing.patch
#Standalone patches
diff --git a/autohide.patch b/autohide.patch
index d708dea759d..7f4aa585a01 100644
--- a/autohide.patch
+++ b/autohide.patch
@@ -109,7 +109,7 @@ index c48b5ea..81ec2f2 100644
return true;
}
-@@ -91,7 +115,147 @@ public class Wingpanel.PanelWindow : Gtk.Window {
+@@ -91,7 +115,151 @@ public class Wingpanel.PanelWindow : Gtk.Window {
Services.BackgroundManager.initialize (this.monitor_number, panel_height);
@@ -220,7 +220,7 @@ index c48b5ea..81ec2f2 100644
+ if (timeout > 0) {
+ Source.remove (timeout);
+ }
-+ if (popover_manager.current_indicator == null) {
++ if (popover_manager.current_indicator == null && autohide != "Disabled") {
+ Thread.usleep (autohide_delay * 1000);
+ }
+ if (autohide == "Dodge-Float" || autohide == "Float") {
@@ -229,7 +229,11 @@ index c48b5ea..81ec2f2 100644
+ strut = true;
+ }
+ hiding = false;
-+ timeout = Timeout.add (100 / panel_height, animation_step);
++ if (autohide == "Disabled") {
++ timeout = Timeout.add (300 / panel_height, animation_step);
++ } else {
++ timeout = Timeout.add (100 / panel_height, animation_step);
++ }
+ return true;
+ }
+
@@ -308,7 +312,7 @@ index 3bcd0a7..eeecbb8 100644
)
set (LIB_PKG
-@@ -84,11 +85,14 @@
+@@ -84,11 +85,15 @@
gee-0.8
gmodule-2.0
gtk+-3.0>=3.22
@@ -318,8 +322,22 @@ index 3bcd0a7..eeecbb8 100644
pkg_check_modules (LIB REQUIRED ${LIB_PKG})
-+add_definitions (-DWNCK_I_KNOW_THIS_IS_UNSTABLE)
++add_definitions (-DWNCK_I_KNOW_THIS_IS_UNSTABLE ${WNCK_CFLAGS})
++link_libraries (${WNCK_LIBRARIES})
+
set (GLOBAL_VALAC_OPTIONS
--vapidir=${CMAKE_BINARY_DIR}/lib
--vapidir=vapi
+diff --git a/.travis.yml b/.travis.yml
+index dddddf1..4efb6c0 100644
+--- src/wingpanel/.travis.yml
++++ src/wingpanel/.travis.yml
+@@ -4,7 +4,7 @@ services:
+ - docker
+
+ env:
+- - DEPENDENCY_PACKAGES="cmake libgala-dev libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev valac"
++ - DEPENDENCY_PACKAGES="cmake libgala-dev libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev libwnck-3-dev valac"
+
+ install:
+ - docker pull elementary/docker:juno-unstable
diff --git a/minus-gala.patch b/minus-gala.patch
index f6c93f4d0f6..2adf145e0a5 100644
--- a/minus-gala.patch
+++ b/minus-gala.patch
@@ -4,8 +4,8 @@
- docker
env:
-- - DEPENDENCY_PACKAGES="cmake libgala-dev libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev valac"
-+ - DEPENDENCY_PACKAGES="cmake libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev valac"
+- - DEPENDENCY_PACKAGES="cmake libgala-dev libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev libwnck-3-dev valac"
++ - DEPENDENCY_PACKAGES="cmake libgee-0.8-dev libgirepository1.0-dev libglib2.0-dev libgranite-dev libgtk-3-dev libwnck-3-dev valac"
install:
- docker pull elementary/docker:loki