summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarodseth2013-03-27 16:36:56 +0000
committerSantiago Torres Arias2013-03-27 16:36:56 +0000
commit703a3f577d098906716a574fdfa5dde3b8e8694a (patch)
treeaf86ffb981e936c8be015263a99c6c5d1369accb
parent70de85ec12ce517c72ac51b29f267c00478aea99 (diff)
downloadaur-703a3f577d098906716a574fdfa5dde3b8e8694a.tar.gz
upgpkg: wings3d 1.4.1-17
git-svn-id: file:///srv/repos/svn-community/svn@87125 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
-rw-r--r--wings3d.sh2
3 files changed, 36 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35306743f6f2..e34898afd4e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = wings3d
pkgdesc = 3D modeling program
pkgver = 1.4.1
- pkgrel = 16
+ pkgrel = 17
url = http://www.wings3d.com/
install = wings3d.install
arch = x86_64
arch = i686
license = GPL
- makedepends = setconf
makedepends = gendesk
- depends = lib32-libgl
- depends = lib32-glu
- depends = lib32-sdl
- depends = lib32-ncurses
+ depends = erlang-sdl
+ depends = erlang-cl
+ depends = bash
+ depends = desktop-file-utils
+ depends = erlang
optdepends = povray: rendering support via POV-Ray
- options = !emptydirs
- source = http://sourceforge.net/projects/wings/files/wings/1.4.1/wings-1.4.1-linux.bzip2.run.gz
+ source = wings3d-1.4.1.tar.gz::https://github.com/dgud/wings/archive/master.tar.gz
+ source = wings3d.sh
source = wings3d.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png
- sha256sums = 760e19fa4973ed0fc75057897135a8efa241e834b078fc05c28786672137b322
+ sha256sums = 5fe17aa7bd26c031ca242f17b24eaa8f6fa9fe4c38b37a9669953c03e9e89b83
+ sha256sums = 46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e
sha256sums = 6658977cc3bc8db2c9358edf3a2d6cb6bb8084c9a1d96ca573a83dd4e8781f1a
pkgname = wings3d
diff --git a/PKGBUILD b/PKGBUILD
index bb977186fff2..40e44cb3e916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,51 +5,49 @@
pkgname=wings3d
_pkgname=wings
pkgver=1.4.1
-pkgrel=16
+pkgrel=17
pkgdesc='3D modeling program'
arch=('x86_64' 'i686')
url='http://www.wings3d.com/'
license=('GPL')
-depends=('erlang' 'erlang-sdl' 'erlang-cl' 'bash' 'desktop-file-utils')
-makedepends=('setconf' 'gendesk')
+depends=('erlang-sdl' 'erlang-cl' 'bash' 'desktop-file-utils' 'erlang')
+makedepends=('gendesk')
optdepends=('povray: rendering support via POV-Ray')
install=$pkgname.install
-options=('!emptydirs')
-_genericname=('3D Modeler')
-_categories=('Graphics;3DGraphics;')
-
-# Using the i686-only binary release.
-# - Would prefer using a source release, if there is one that compiles.
-source=("http://sourceforge.net/projects/$_pkgname/files/$_pkgname/$pkgver/$_pkgname-$pkgver-linux.bzip2.run.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/dgud/wings/archive/master.tar.gz"
+ "$pkgname.sh"
"$pkgname.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png")
-sha256sums=('760e19fa4973ed0fc75057897135a8efa241e834b078fc05c28786672137b322'
+sha256sums=('5fe17aa7bd26c031ca242f17b24eaa8f6fa9fe4c38b37a9669953c03e9e89b83'
+ '46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e'
'6658977cc3bc8db2c9358edf3a2d6cb6bb8084c9a1d96ca573a83dd4e8781f1a')
-if [ "$CARCH" == "x86_64" ]
-then
- depends=('lib32-libgl' 'lib32-glu' 'lib32-sdl' 'lib32-ncurses')
-fi
+_genericname=('3D Modeler')
+_categories=('Graphics;3DGraphics')
build() {
cd "$srcdir"
-
gendesk
- chmod +x "$_pkgname-$pkgver-linux.bzip2.run"
- "./$_pkgname-$pkgver-linux.bzip2.run" --nox11 --nochown --tar xf > /dev/null
- setconf install_wings INSTALL_DIR "$pkgdir/opt/$pkgname-$pkgver"
+
+ cd "$_pkgname-master"
+ export ESDL_PATH=$(echo /usr/lib/erlang/lib/esdl-*)
+ make
+ make lang
}
package() {
- cd "$srcdir"
+ cd "$srcdir/$_pkgname-master"
+
+ mkdir -p "$pkgdir/usr/lib/$pkgname"
+ for subdir in ebin fonts patches plugins shaders textures; do
+ cp -r "$srcdir/$_pkgname-master/$subdir/" "$pkgdir/usr/lib/$pkgname"
+ done
+
+ install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- ./install_wings
- cd "$pkgdir"
- setconf "opt/$pkgname-$pkgver/$_pkgname" ROOTDIR "/opt/$pkgname-$pkgver"
- install -Dm755 "opt/$pkgname-$pkgver/$_pkgname" "$pkgdir/usr/bin/$pkgname"
cd "$srcdir"
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et:
diff --git a/wings3d.sh b/wings3d.sh
new file mode 100644
index 000000000000..c0fd3b2fbe3a
--- /dev/null
+++ b/wings3d.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+erl -noinput -smp disable -pa /usr/lib/erlang/lib/esdl-*/ebin /usr/lib/wings3d/ebin -run wings_start start_halt ${1+"$@"}