summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:15:33 -0600
committernot_anonymous2015-07-05 18:15:33 -0600
commit9d37a12f6e3e005dcaa1d6391c00ef53070e98e8 (patch)
tree8677a6cad7348e300d4c5c9cc19781cb1fe378ad
downloadaur-9d37a12f6e3e005dcaa1d6391c00ef53070e98e8.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--winkeydaemon.838
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2b16697dd51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = winkeydaemon
+ pkgdesc = API for sending CW (Morse Code) with K1EL's USB devices
+ pkgver = 1.0.PE7T
+ pkgrel = 2
+ url = http://home.kpn.nl/w.knol18/qle/winkeyer/index.html
+ arch = any
+ license = GPL
+ depends = perl-device-serialport
+ source = http://home.kpn.nl/w.knol18/qle/winkeyer/winkeydaemon-1.0.PE7T-2.gz
+ source = winkeydaemon.8
+ md5sums = f8a9e7aa551446ac26798f250919d849
+ md5sums = 5d9ec64280698a6e9878a4d3e1a869b1
+ sha256sums = f93a1301443c08ab8eea58d50e021257da03066fec61f9ba4bb229f664aef084
+ sha256sums = 9e2e19b5cc66edf29104853b0b7502dbeae5cc9a20a584c46933b0d38f682176
+
+pkgname = winkeydaemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c002ecba1e35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=winkeydaemon
+pkgver=1.0.PE7T
+pkgrel=2
+pkgdesc="API for sending CW (Morse Code) with K1EL's USB devices"
+arch=('any')
+url="http://home.kpn.nl/w.knol18/qle/winkeyer/index.html"
+license=('GPL')
+depends=('perl-device-serialport')
+source=(http://home.kpn.nl/w.knol18/qle/winkeyer/$pkgname-$pkgver-2.gz
+ $pkgname.8)
+
+package() {
+ cd "$srcdir/"
+ install -d $pkgdir/usr/bin
+ install -D -m 755 $pkgname-$pkgver-2 $pkgdir/usr/bin/.
+
+ mkdir -p $pkgdir/usr/share/man/man8
+ install -D -m 644 $pkgname.8 $pkgdir/usr/share/man/man8/.
+}
+md5sums=('f8a9e7aa551446ac26798f250919d849'
+ '5d9ec64280698a6e9878a4d3e1a869b1')
+sha256sums=('f93a1301443c08ab8eea58d50e021257da03066fec61f9ba4bb229f664aef084'
+ '9e2e19b5cc66edf29104853b0b7502dbeae5cc9a20a584c46933b0d38f682176')
diff --git a/winkeydaemon.8 b/winkeydaemon.8
new file mode 100644
index 000000000000..ad34b9f0e40f
--- /dev/null
+++ b/winkeydaemon.8
@@ -0,0 +1,38 @@
+.TH WINKEYDAEMON 8
+
+.SH NAME
+winkeydaemon \- morse daemon for the winkey hardware keyer module
+
+.SH SYNOPSIS
+.B winkeydaemon
+.RI [ options ]
+
+.SH DESCRIPTION
+This manual page documents briefly the
+.B winkeydaemon command.
+.PP
+\fBwinkeydaemon\fP is a program to control the the winkey2 keyer. It provides
+an interface which is compatible to the cwdaemon, which means it can be used
+instead of cwdaemon. Winkeydaemon listens on a udp socket and outputs commands
+to the K1EL keyer on a serial port.
+
+.SH OPTIONS
+A summary of options is included below.
+.TP
+.B -n
+Run in debug mode.
+.TP
+.B -p
+UDP port to be used (default is 6789).
+.TP
+.B -s
+Speed (default is 24 wpm).
+.TP
+.B -d
+Serial device to be used(default is /dev/ttyS0).
+
+.SH AUTHOR
+winkeydaemon was written by Rein Couperus.
+.PP
+This manual page was written by Joop Stakenborg <pa3aba@debian.org>,
+for the Debian project (but may be used by others).