summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorms2015-12-03 20:47:06 +0700
committerms2015-12-03 20:47:06 +0700
commit7c7770b6698e1c104a571a668ab029d817cfa50e (patch)
tree48daacd140ec0a5e27fb5d0622fd571b773e9806
downloadaur-7c7770b6698e1c104a571a668ab029d817cfa50e.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9ed44fa37a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = winregfs-git
+ pkgdesc = Windows Registry FUSE filesystem
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/jbruchon/winregfs
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ options = !emptydirs
+ source = https://github.com/jbruchon/winregfs/archive/master.zip
+ md5sums = 9782599b550fa7bd8047fe555ad0c7e4
+
+pkgname = winregfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5497cd0ab708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer and Contributor: Vladimir Kamensky <mastersoft24@yandex.ru>
+
+
+pkgname=winregfs-git
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Windows Registry FUSE filesystem "
+arch=('i686' 'x86_64')
+url="https://github.com/jbruchon/winregfs"
+license=('GPL')
+categories=('utility')
+#if [ "${CARCH}" = 'x86_64' ]; then
+# depends=('gcc-libs-multilib' 'lib32-curl' 'lib32-json-c' 'lib32-openssl' 'boost' 'lib32-libgcrypt' 'lib32-#expat' 'yajl')
+#elif [ "${CARCH}" = 'i686' ]; then
+# depends=('gcc-libs' 'curl' 'json-c' 'openssl' 'boost-libs' 'libgcrypt' 'expat' 'yajl')
+#fi
+
+depends=()
+#makedepends=('cmake' 'cppunit' 'boost')
+makedepends=('make' )
+options=(!emptydirs)
+
+source=("https://github.com/jbruchon/winregfs/archive/master.zip")
+
+md5sums=("9782599b550fa7bd8047fe555ad0c7e4")
+
+
+build() {
+ cd "$srcdir/winregfs-master"
+
+
+
+
+ rm -rf build
+ mkdir build
+# cd build
+# cmake .. -DCMAKE_BUILD_TYPE=Release \
+# -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_EXE_LINKER_FLAGS=-ljson-c
+
+ make
+# make DESTDIR="$srcdir/winregfs-master/build" install
+}
+
+package() {
+ cd "$srcdir/winregfs-master"
+
+# make DESTDIR="$srcdir/winregfs-master/build" install
+
+ make DESTDIR="$pkgdir" install
+
+# #mkdir "${pkgdir}/usr/lib"
+ #ln -s "/usr/lib/libboost_program_options.so" "${pkgdir}/usr/lib/libbost_program_options.so.1.56.0"
+ #ln -s "/usr/lib/libboost_filesystem.so" "${pkgdir}/usr/lib/libboost_filesystem.so.1.56"
+
+}