summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-03-19 18:42:53 +0100
committerMarco Rubin2022-03-19 18:42:53 +0100
commit0a59b108491c0c6d2916436459da48d94286ccd5 (patch)
tree30874f23bb649ff941b2cbb27de48a30cd43eced
downloadaur-0a59b108491c0c6d2916436459da48d94286ccd5.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23f9606f0be1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wio-wl
+ pkgdesc = Wayland compositor similar to Plan 9's rio
+ pkgver = 0.15.1
+ pkgrel = 1
+ url = https://gitlab.com/Rubo/wio
+ arch = x86_64
+ license = custom
+ makedepends = meson
+ depends = alacritty
+ depends = cage
+ depends = cairo
+ depends = wlroots
+ options = strip
+ source = https://gitlab.com/Rubo/wio/-/archive/0.15.1/wio-0.15.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = wio-wl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..523274e9d19c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+
+pkgname=wio-wl
+pkgver=0.15.1
+pkgrel=1
+pkgdesc="Wayland compositor similar to Plan 9's rio"
+arch=(x86_64)
+url='https://gitlab.com/Rubo/wio'
+license=('custom')
+depends=(alacritty cage cairo wlroots)
+options=(strip)
+makedepends=(meson)
+source=("https://gitlab.com/Rubo/wio/-/archive/$pkgver/wio-$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+
+build() {
+ cd wio-$pkgver
+ arch-meson build
+ meson compile -C build
+}
+
+package() {
+ cd wio-$pkgver
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ meson install -C build --destdir "$pkgdir"
+}