summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2023-11-23 14:26:40 +0100
committerMarco Rubin2023-11-23 14:26:40 +0100
commitb2e661efd74adc44f7a215006bef46be1fc11a92 (patch)
tree76fd0fe6467c4b8f5f6fea4f522eb1f8f4a80423
parente4d5a73e1d1183673354854220afb85619e8d553 (diff)
downloadaur-b2e661efd74adc44f7a215006bef46be1fc11a92.tar.gz
0.17.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7660b8f61c2..f64f01841f7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wio-wl
pkgdesc = Wayland compositor similar to Plan 9's rio
- pkgver = 0.16.2
+ pkgver = 0.17.0
pkgrel = 1
url = https://gitlab.com/Rubo/wio
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = wio-wl
depends = alacritty
depends = cage
depends = cairo
- depends = wlroots
- source = https://gitlab.com/Rubo/wio/-/archive/0.16.2/wio-0.16.2.tar.gz
- b2sums = 725a180244360c84fbe81729158351eabef0c562039e6c90a890d3aee6d3b17376c00abf7dcf596a83e8781a2c8481ebd50f15454a8f69f7bb4e40a19fd8fe31
+ depends = wlroots>=0.17.0
+ source = https://gitlab.com/Rubo/wio/-/archive/0.17.0/wio-0.17.0.tar.gz
+ b2sums = d0ebb5b70264ec3c7d72cfa4f8f8921ea795912cbd2905450f61a91ff47b7ff77b2032c0feeedf494f344e90974a728923b9cdf59f15df5917381e953a3e9849
pkgname = wio-wl
diff --git a/PKGBUILD b/PKGBUILD
index f45e4d5047b9..364e7df59a22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
-pkgname=wio-wl
-pkgver=0.16.2
+_name=wio
+pkgname=$_name-wl
+pkgver=0.17.0
pkgrel=1
pkgdesc="Wayland compositor similar to Plan 9's rio"
arch=(x86_64)
url='https://gitlab.com/Rubo/wio'
license=('custom')
-depends=(alacritty cage cairo wlroots)
+depends=(alacritty cage cairo "wlroots>=$pkgver")
makedepends=(meson)
-source=("$url/-/archive/$pkgver/wio-$pkgver.tar.gz")
-b2sums=('725a180244360c84fbe81729158351eabef0c562039e6c90a890d3aee6d3b17376c00abf7dcf596a83e8781a2c8481ebd50f15454a8f69f7bb4e40a19fd8fe31')
+source=("$url/-/archive/$pkgver/$_name-$pkgver.tar.gz")
+b2sums=('d0ebb5b70264ec3c7d72cfa4f8f8921ea795912cbd2905450f61a91ff47b7ff77b2032c0feeedf494f344e90974a728923b9cdf59f15df5917381e953a3e9849')
build() {
- cd wio-$pkgver
+ cd $_name-$pkgver
arch-meson build
meson compile -C build
}
package() {
- cd wio-$pkgver
+ cd $_name-$pkgver
meson install -C build --destdir "$pkgdir"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}