summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruint2023-11-25 17:42:36 -0800
committeruint2023-11-25 17:42:36 -0800
commitc8b3e831a51c1d1867f8ab13bcd7e4d58c504c42 (patch)
treed0656964b40ecba16d20672825327866d1c940d5
parent16accff156a6b93f8860037098ca20bfc37d03c7 (diff)
downloadaur-c8b3e831a51c1d1867f8ab13bcd7e4d58c504c42.tar.gz
Switch to cmake, fix sound
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 591755afe58a..6deb86a02c05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = wipeout-rewrite-git
pkgdesc = A re-implementation of the 1995 PSX game wipEout
- pkgver = 9e90c47
+ pkgver = 90702ce
pkgrel = 1
url = https://github.com/phoboslab/wipeout-rewrite
arch = x86_64
license = custom
makedepends = git
- makedepends = make
+ makedepends = cmake
makedepends = gcc
makedepends = imagemagick
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 5fb56049a39a..0b1f8d8b962a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: uint2048_t
pkgname=wipeout-rewrite-git
-pkgver=9e90c47
+pkgver=90702ce
pkgrel=1
pkgdesc="A re-implementation of the 1995 PSX game wipEout"
arch=(x86_64)
url="https://github.com/phoboslab/wipeout-rewrite"
license=(custom)
depends=(sdl2 glew)
-makedepends=(git make gcc imagemagick)
+makedepends=(git cmake gcc imagemagick)
source=("git+https://github.com/phoboslab/wipeout-rewrite.git"
"https://archive.org/download/wipeout-data.tar/wipeout-data.tar.zst"
@@ -26,13 +26,17 @@ pkgver() {
}
build() {
+ mkdir wipeout-rewrite/build
cd wipeout-rewrite
- make sdl
+ #cmake ..
+ #cmake --build .
+ cmake -B build -S .
+ cmake --build build
}
package() {
install -dm757 "${pkgdir}"/opt/wipeout-rewrite
- install -Dm755 "${srcdir}/wipeout-rewrite/wipegame" "${pkgdir}/opt/wipeout-rewrite"
+ install -Dm755 "${srcdir}/wipeout-rewrite/build/wipeout" "${pkgdir}/opt/wipeout-rewrite/wipegame"
cp -rv "wipeout" "${pkgdir}/opt/wipeout-rewrite"
for _size in "512x512" "256x256" "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
do