summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruint204t2023-08-26 23:05:53 +0000
committeruint204t2023-08-26 23:05:53 +0000
commitcc2decd3ab5e5c3663a40c3c1541c243e4645bea (patch)
tree3bb67e168863abfd6ef66c25116b267ddfccc4d5
downloadaur-cc2decd3ab5e5c3663a40c3c1541c243e4645bea.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD40
-rw-r--r--wipeout.desktop19
-rw-r--r--wipeout.pngbin0 -> 475649 bytes
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9e24b643d49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wipeout-rewrite-git
+ pkgdesc = A re-implementation of the 1995 PSX game wipEout
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/phoboslab/wipeout-rewrite
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ depends = sdl2
+ depends = glew
+ source = git+https://github.com/phoboslab/wipeout-rewrite.git
+ source = https://phoboslab.org/files/wipeout-data-v01.zip
+ source = wipeout.png
+ source = wipeout.desktop
+ sha256sums = SKIP
+ sha256sums = 5bc02de7118a62a5cb8b4d0ec79062cddbe20ced86dda594df8a10c455f90ad1
+ sha256sums = 9374b04f78bd925661decd8cc8832598d7c53e6f477f71edd5eee02d6f09a3e5
+ sha256sums = 32343d744be32a80fa3cd44f8318a974a01cbb15beee03e29c85a082d707e496
+
+pkgname = wipeout-rewrite-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6bc181a9e938
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: uint2048_t
+pkgname=wipeout-rewrite-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="A re-implementation of the 1995 PSX game wipEout"
+arch=(x86_64)
+url="https://github.com/phoboslab/wipeout-rewrite"
+license=(custom)
+
+depends=(sdl2 glew)
+
+makedepends=(cmake git)
+
+source=("git+https://github.com/phoboslab/wipeout-rewrite.git"
+ "https://phoboslab.org/files/wipeout-data-v01.zip"
+ "wipeout.png"
+ "wipeout.desktop")
+
+sha256sums=('SKIP'
+ '5bc02de7118a62a5cb8b4d0ec79062cddbe20ced86dda594df8a10c455f90ad1'
+ '9374b04f78bd925661decd8cc8832598d7c53e6f477f71edd5eee02d6f09a3e5'
+ '32343d744be32a80fa3cd44f8318a974a01cbb15beee03e29c85a082d707e496')
+
+build() {
+ cd wipeout-rewrite
+ make sdl
+}
+
+package() {
+ mkdir -pv "${pkgdir}/opt/wipeout-rewrite/"
+ install -Dm755 "wipeout-rewrite/wipegame" "${pkgdir}/opt/wipeout-rewrite"
+ cp -rv "wipeout" "${pkgdir}/opt/wipeout-rewrite"
+ chmod -v 777 "${pkgdir}/opt/wipeout-rewrite"
+ for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
+ do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/${_size}/apps"
+ convert "${srcdir}/wipeout.png" -resize "${_size}" "${pkgdir}/usr/share/icons/hicolor/${_size}/apps/wipeout.png"
+ done
+ install -Dm644 "${srcdir}/wipeout.desktop" "${pkgdir}/usr/share/applications/wipeout.desktop"
+}
diff --git a/wipeout.desktop b/wipeout.desktop
new file mode 100644
index 000000000000..38824bdacef9
--- /dev/null
+++ b/wipeout.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Categories=Game
+Comment[en_US]=
+Comment=
+Exec=/opt/wipeout-rewrite/wipegame
+GenericName[en_US]=
+GenericName=
+Icon=wipeout
+MimeType=
+Name[en_US]=WipEout
+Name=WipEout
+Path=/opt/wipeout-rewrite
+StartupNotify=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Version=1.0
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/wipeout.png b/wipeout.png
new file mode 100644
index 000000000000..b9409d38b257
--- /dev/null
+++ b/wipeout.png
Binary files differ