summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruint204t2023-09-01 05:00:24 +0000
committeruint204t2023-09-01 05:00:24 +0000
commitede09dc762b8caa84e85af9719ffb958d8d6c145 (patch)
tree63541bdce91532a509e2acec72fa42ccc4d7dff1
parent8766a0a30d3f8e3fed556ffc0b2a758ffecf7fcb (diff)
downloadaur-ede09dc762b8caa84e85af9719ffb958d8d6c145.tar.gz
fix permissions
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dc2da059b26..fa5fdd40d372 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,9 @@ pkgbase = wipeout-rewrite-git
url = https://github.com/phoboslab/wipeout-rewrite
arch = x86_64
license = custom
+ makedepends = git
makedepends = make
makedepends = gcc
- makedepends = git
makedepends = imagemagick
depends = sdl2
depends = glew
diff --git a/PKGBUILD b/PKGBUILD
index 1b57ac506229..57dd240c644d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=(x86_64)
url="https://github.com/phoboslab/wipeout-rewrite"
license=(custom)
depends=(sdl2 glew)
-makedepends=(make gcc git imagemagick)
+makedepends=(git make gcc imagemagick)
source=("git+https://github.com/phoboslab/wipeout-rewrite.git"
"https://archive.org/download/wipeout-data.tar/wipeout-data.tar.zst"
@@ -32,13 +32,12 @@ build() {
package() {
install -d "$pkgdir"/opt/wipeout-rewrite
- #install -Dm755 "wipeout-rewrite/wipegame" "${pkgdir}/opt/wipeout-rewrite"
+ install -Dm755 "wipeout-rewrite/wipegame" "${pkgdir}/opt/wipeout-rewrite"
cp -rv "wipeout" "${pkgdir}/opt/wipeout-rewrite"
- install -dm755 "{$srcdir}"/wipeout/* ${pkgdir}/opt/wipeout-rewrite/wipeout
chmod -v 757 "${pkgdir}/opt/wipeout-rewrite" # workaround because the game only saves to the the current dir
for _size in "512x512" "256x256" "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
do
- install -dm755 "${pkgdir}/usr/share/icons/hicolor/${_size}/apps"
+ install -dm644 "${pkgdir}/usr/share/icons/hicolor/${_size}/apps"
convert "${srcdir}/wipeout.png" -resize "${_size}" "${pkgdir}/usr/share/icons/hicolor/${_size}/apps/wipeout.png"
done
install -Dm644 "${srcdir}/wipeout.desktop" "${pkgdir}/usr/share/applications/wipeout.desktop"