summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Baz2018-12-30 13:33:50 +0100
committerGitHub2018-12-30 13:33:50 +0100
commit24e893b34040e5598792a5d5de1a8fdbe2825004 (patch)
treee876e84315ce46a2b53994a4f95ea7205ed9b094
parentb0bd8358c9861d9fd0fabfb39993ea2c5741d54e (diff)
downloadaur-24e893b34040e5598792a5d5de1a8fdbe2825004.tar.gz
Update wire-desktop-beta and -git, -beta doesn't conflict with wire-desktop (#3)
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
-rw-r--r--wire-desktop-beta.desktop (renamed from wire-desktop.desktop)6
3 files changed, 42 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b9d4c4fc352..deeddac4035a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,23 @@
pkgbase = wire-desktop-beta
- pkgdesc = Modern, private messenger. Based on Electron.
+ pkgdesc = End-to-end encrypted messenger with file sharing, voice calls and video conferences
pkgver = 3.5.2881
- pkgrel = 1
+ pkgrel = 2
url = https://wire.com/
arch = x86_64
- arch = i686
license = GPL3
makedepends = cargo
makedepends = npm
makedepends = python2
makedepends = git
makedepends = yarn
- depends = alsa-lib
- depends = gconf
- depends = gtk2
- depends = libxss
- depends = libxtst
- depends = nss
+ depends = electron
depends = xdg-utils
- optdepends = hunspell-en: for English spellcheck support
- optdepends = noto-fonts-emoji: for colorful emoji made by Google
- optdepends = ttf-emojione: for colorful emoji made by EmojiOne
- provides = wire-desktop
- conflicts = wire-desktop-bin
- conflicts = wire-desktop
- conflicts = wire-desktop-git
- source = 3.5.2881.tar.gz::https://github.com/wireapp/wire-desktop/archive/linux/3.5.2881.tar.gz
- source = wire-desktop.desktop
+ optdepends = hunspell-en_US: for English spellcheck support
+ optdepends = emoji-font: colorful emoji
+ source = wire-desktop-beta-3.5.2881.tar.gz::https://github.com/wireapp/wire-desktop/archive/linux/3.5.2881.tar.gz
+ source = wire-desktop-beta.desktop
sha256sums = 4216cd9c3a2c4920aec2f3c967181b04bfafdb1b47e526a8e823911cce704da1
- sha256sums = cc9056cecff2aa49a9ce9c8376d57ec8c7c2cb8174f7966b5cdccbeb2e3751ea
+ sha256sums = 79505a8ae908a26f74af3d72c24cb09815dc5688eca26ee4bbf57362a865d7c5
pkgname = wire-desktop-beta
diff --git a/PKGBUILD b/PKGBUILD
index 5000f1e37037..a85648a99854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
# Maintainer: Conor Anderson <conor@conr.ca>
-# Maintainer: Maxim Baz <$_pkgname at maximbaz dot com>
+# Maintainer: Maxim Baz <$pkgname at maximbaz dot com>
pkgname=wire-desktop-beta
_pkgname=${pkgname%-beta}
pkgver=3.5.2881
-pkgrel=1
-pkgdesc='Modern, private messenger. Based on Electron.'
-arch=('x86_64' 'i686')
+pkgrel=2
+pkgdesc='End-to-end encrypted messenger with file sharing, voice calls and video conferences'
+arch=('x86_64')
url='https://wire.com/'
license=('GPL3')
-conflicts=('wire-desktop-bin' 'wire-desktop' 'wire-desktop-git')
-depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss' 'xdg-utils')
+depends=('electron' 'xdg-utils')
makedepends=('cargo' 'npm' 'python2' 'git' 'yarn')
-optdepends=('hunspell-en: for English spellcheck support'
- 'noto-fonts-emoji: for colorful emoji made by Google'
- 'ttf-emojione: for colorful emoji made by EmojiOne')
-provides=('wire-desktop')
-source=("${pkgver}.tar.gz::https://github.com/wireapp/wire-desktop/archive/linux/${pkgver}.tar.gz"
- "${_pkgname}.desktop")
+optdepends=('hunspell-en_US: for English spellcheck support'
+ 'emoji-font: colorful emoji')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wireapp/${_pkgname}/archive/linux/${pkgver}.tar.gz"
+ "${pkgname}.desktop")
sha256sums=('4216cd9c3a2c4920aec2f3c967181b04bfafdb1b47e526a8e823911cce704da1'
- 'cc9056cecff2aa49a9ce9c8376d57ec8c7c2cb8174f7966b5cdccbeb2e3751ea')
+ '79505a8ae908a26f74af3d72c24cb09815dc5688eca26ee4bbf57362a865d7c5')
+
+prepare() {
+ # Create launcher script
+ cat << EOF > "${pkgname}"
+#!/bin/sh
+
+electron "/usr/lib/${pkgname}"
+EOF
+}
build() {
- cd "${srcdir}/${_pkgname}-linux-${pkgver}"
+ cd "${_pkgname}-linux-${pkgver}"
yarn
yarn build:ts
npx grunt 'linux-other-internal'
@@ -30,28 +36,26 @@ build() {
package() {
# Place files
- install -d "${pkgdir}/usr/lib/${_pkgname}"
- cp -a "${srcdir}/${_pkgname}-linux-${pkgver}"/wrap/dist/linux*unpacked/* "${pkgdir}/usr/lib/${_pkgname}"
+ install -d "${pkgdir}/usr/lib/${pkgname}"
+ cp -a "${_pkgname}-linux-${pkgver}"/wrap/dist/linux-unpacked/resources/app/* "${pkgdir}/usr/lib/${pkgname}"
- # Symlink main binary
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ # Place launcher script
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
# Place desktop entry and icon
- desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/${_pkgname}.desktop"
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${pkgname}.desktop"
+ local res
for res in 32x32 256x256; do
- install -dm755 "${pkgdir}/usr/share/icons/hicolor/${res}/apps"
- install -Dm644 "${srcdir}/${_pkgname}-linux-${pkgver}/resources/icons/${res}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${res}/apps/${_pkgname}.png"
+ install -Dm644 "${_pkgname}-linux-${pkgver}/resources/icons/${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/${pkgname}.png"
done
# Spellcheck dictionaries
- rm -rf "${pkgdir}/usr/lib/${_pkgname}/resources/app/node_modules/spellchecker/vendor/hunspell_dictionaries"
- ln -s "/usr/share/hunspell" "${pkgdir}/usr/lib/${_pkgname}/resources/app/node_modules/spellchecker/vendor/hunspell_dictionaries"
+ rm -rf "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
+ ln -s "/usr/share/hunspell" "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
# Place license files
+ local license
for license in "LICENSE.electron.txt" "LICENSES.chromium.html"; do
- install -Dm644 "${pkgdir}/usr/lib/${_pkgname}/${license}" "${pkgdir}/usr/share/licenses/${_pkgname}/${license}"
- rm "${pkgdir}/usr/lib/${_pkgname}/${license}"
+ install -Dm644 "${_pkgname}-linux-${pkgver}/wrap/dist/linux-unpacked/${license}" "${pkgdir}/usr/share/licenses/${pkgname}/${license}"
done
}
diff --git a/wire-desktop.desktop b/wire-desktop-beta.desktop
index e9fdcbb4bf10..7c0184140984 100644
--- a/wire-desktop.desktop
+++ b/wire-desktop-beta.desktop
@@ -1,11 +1,11 @@
[Desktop Entry]
Type=Application
Version=1.1
-Name=Wire
+Name=Wire (beta)
GenericName=Secure messenger
Comment=Secure messenger for everyone
-Exec=wire-desktop
-Icon=wire-desktop
+Exec=wire-desktop-beta
+Icon=wire-desktop-beta
Terminal=false
Categories=Network;InstantMessaging;Chat;VideoConference
Keywords=chat;encrypt;e2e;messenger;videocall