summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Baz2019-01-10 22:41:52 +0100
committerMaxim Baz2019-01-10 22:41:52 +0100
commit62d21d876f274fd174780a9eee9d6bf81f5ae4b3 (patch)
treed1068ab1b7abb282bd242f57928b6f18b1e283cc
parentd76c6d5252a1dfb3dbe661d06f2a0711b9a1a6cb (diff)
downloadaur-62d21d876f274fd174780a9eee9d6bf81f5ae4b3.tar.gz
wire-desktop: use 4 spaces for tab
-rw-r--r--PKGBUILD56
1 files changed, 29 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42051550f5dc..024b6ed93fc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,13 +19,13 @@ sha256sums=('4216cd9c3a2c4920aec2f3c967181b04bfafdb1b47e526a8e823911cce704da1'
'79505a8ae908a26f74af3d72c24cb09815dc5688eca26ee4bbf57362a865d7c5')
prepare() {
- # Ensure we compile native extensions against system electron version
- local electronver="$(sed 's/^[^0-9]*//' /usr/lib/electron/version)"
- msg2 "Compiling against system electron version: $electronver"
- sed -i 's/"electron": ".*"/"electron": "'"$electronver"'"/' "${_pkgname}-linux-${pkgver}/package.json"
+ # Ensure we compile native extensions against system electron version
+ local electronver="$(sed 's/^[^0-9]*//' /usr/lib/electron/version)"
+ msg2 "Compiling against system electron version: $electronver"
+ sed -i 's/"electron": ".*"/"electron": "'"$electronver"'"/' "${_pkgname}-linux-${pkgver}/package.json"
- # Create launcher script
- cat << EOF > "${pkgname}"
+ # Create launcher script
+ cat << EOF > "${pkgname}"
#!/bin/sh
electron "/usr/lib/${pkgname}" "\$@"
@@ -33,28 +33,30 @@ EOF
}
build() {
- cd "${_pkgname}-linux-${pkgver}"
- yarn
- yarn build:ts
- npx grunt 'clean:linux' 'update-keys' 'gitinfo' 'release-internal' 'bundle'
+ cd "${_pkgname}-linux-${pkgver}"
+ yarn
+ yarn build:ts
+ npx grunt 'clean:linux' 'update-keys' 'gitinfo' 'release-internal' 'bundle'
}
package() {
- # Place files
- install -d "${pkgdir}/usr/lib/${pkgname}"
- cp -a "${_pkgname}-linux-${pkgver}/electron"/* "${pkgdir}/usr/lib/${pkgname}"
-
- # Place launcher script
- install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
-
- # Place desktop entry and icon
- desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${pkgname}.desktop"
- local res
- for res in 32x32 256x256; do
- install -Dm644 "${_pkgname}-linux-${pkgver}/resources/icons/${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/${pkgname}.png"
- done
-
- # Spellcheck dictionaries
- rm -rf "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
- ln -s "/usr/share/hunspell" "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
+ # Place files
+ install -d "${pkgdir}/usr/lib/${pkgname}"
+ cp -a "${_pkgname}-linux-${pkgver}/electron"/* "${pkgdir}/usr/lib/${pkgname}"
+
+ # Place launcher script
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+
+ # Place desktop entry and icon
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${pkgname}.desktop"
+ local res
+ for res in 32x32 256x256; do
+ install -Dm644 "${_pkgname}-linux-${pkgver}/resources/icons/${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/${pkgname}.png"
+ done
+
+ # Spellcheck dictionaries
+ rm -rf "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
+ ln -s "/usr/share/hunspell" "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
}
+
+# vim:set ts=4 sw=4 et: