summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Palmos2020-10-21 14:10:58 +1000
committerMichael Palmos2020-10-21 14:10:58 +1000
commit9b990abd8e8bb8c3c06789cf133796bb3a5ccb3a (patch)
tree85f8397406845a54a8cf3932d720e02166800a66
downloadaur-9b990abd8e8bb8c3c06789cf133796bb3a5ccb3a.tar.gz
Initial release.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf5a5e5025d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wired
+ pkgdesc = Lightweight notification daemon with highly customizable layout blocks, written in Rust.
+ pkgver = 0.8.0beta
+ pkgrel = 1
+ url = https://github.com/Toqozz/wired-notify
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = dbus
+ depends = cairo
+ depends = pango
+ depends = glib2
+ depends = libx11
+ provides = wired
+ conflicts = wired
+ source = wired-0.8.0beta.tar.gz::https://github.com/Toqozz/wired-notify/archive/v0.8.0beta.tar.gz
+ sha256sums = 092c74ba3aa76311b7aabe15719546daab7427e07756375987832f32b0b30562
+
+pkgname = wired
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed23d23da703
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Toqoz <https://github.com/Toqozz/wired-notify>
+
+pkgname=wired
+_pkgname=wired-notify
+pkgver=0.8.0beta
+pkgrel=1
+pkgdesc="Lightweight notification daemon with highly customizable layout blocks, written in Rust."
+arch=('x86_64' 'i686')
+url="https://github.com/Toqozz/wired-notify"
+license=('MIT')
+depends=('dbus' 'cairo' 'pango' 'glib2' 'libx11')
+makedepends=('rust' 'cargo')
+provides=('wired')
+conflicts=('wired')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Toqozz/wired-notify/archive/v${pkgver}.tar.gz")
+sha256sums=('092c74ba3aa76311b7aabe15719546daab7427e07756375987832f32b0b30562')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ cargo build --release --target-dir "./target"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Install binary.
+ install -Dm 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install MIT license
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+}