summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoungjae Lee2023-12-23 02:06:07 +0900
committerYoungjae Lee2023-12-23 02:06:07 +0900
commitbc9552250116a1e66c895e9781a43ac6fa3fea93 (patch)
treebd773a4bd8621bca01e811239b1c9efea7e757a4
parentb923c8ea5da9c03ad038daf7e0280937d672dcf6 (diff)
downloadaur-bc9552250116a1e66c895e9781a43ac6fa3fea93.tar.gz
WiredTiger 11.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--include_optional.patch12
3 files changed, 6 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74b33a24cb7a..bed46b5c9186 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wiredtiger
pkgdesc = High performance, scalable, NoSQL, extensible platform for data management
- pkgver = 11.1.0
+ pkgver = 11.2.0
pkgrel = 1
url = https://github.com/wiredtiger/wiredtiger
arch = x86_64
@@ -11,9 +11,7 @@ pkgbase = wiredtiger
depends = snappy
depends = zlib
depends = zstd
- source = wiredtiger-11.1.0.tar.gz::https://github.com/wiredtiger/wiredtiger/archive/refs/tags/11.1.0.tar.gz
- source = include_optional.patch
- sha256sums = 0d988a8256219b614d855a2504d252975240171a633b882f19149c4a2ce0ec3d
- sha256sums = c90ae01194c0cdc11c3c967289605ba2ba6fc302ad79fbb7e0e85075b81b85a0
+ source = wiredtiger-11.2.0.tar.gz::https://github.com/wiredtiger/wiredtiger/archive/refs/tags/11.2.0.tar.gz
+ sha256sums = 90d1392a9b10dae5bda02d476cb3204331dcf94b3e47ce5e2ab4d4d9b4dd198c
pkgname = wiredtiger
diff --git a/PKGBUILD b/PKGBUILD
index b95efab73b9d..973501f3bd23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=wiredtiger
-pkgver=11.1.0
+pkgver=11.2.0
pkgrel=1
pkgdesc="High performance, scalable, NoSQL, extensible platform for data management"
arch=("x86_64")
@@ -14,14 +14,8 @@ url="https://github.com/wiredtiger/wiredtiger"
license=("GPL")
depends=("lz4" "snappy" "zlib" "zstd")
makedepends=("cmake" "swig")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/wiredtiger/$pkgname/archive/refs/tags/$pkgver.tar.gz"
- "include_optional.patch")
-sha256sums=("0d988a8256219b614d855a2504d252975240171a633b882f19149c4a2ce0ec3d"
- "c90ae01194c0cdc11c3c967289605ba2ba6fc302ad79fbb7e0e85075b81b85a0")
-
-prepare() {
- patch -d "$pkgname-$pkgver" -p1 < include_optional.patch
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wiredtiger/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=("90d1392a9b10dae5bda02d476cb3204331dcf94b3e47ce5e2ab4d4d9b4dd198c")
build() {
cd "$pkgname-$pkgver"
diff --git a/include_optional.patch b/include_optional.patch
deleted file mode 100644
index a5815f5ad10b..000000000000
--- a/include_optional.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/test/cppsuite/src/main/thread_worker.h b/test/cppsuite/src/main/thread_worker.h
-index afc4c8366..e8376401b 100644
---- a/test/cppsuite/src/main/thread_worker.h
-+++ b/test/cppsuite/src/main/thread_worker.h
-@@ -30,6 +30,7 @@
- #define THREAD_WORKER_H
-
- #include <string>
-+#include <optional>
-
- #include "database.h"
- #include "src/component/operation_tracker.h"