summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-01-27 15:56:17 +0100
committerhaawda2019-01-27 15:56:17 +0100
commitf8f81a18a224f2d154596943657ac5ae744c7dee (patch)
tree2d367b25132a434aaf6edec630f110257f10cafa
parenta62b3f264faa6363086d7a20d08516be2b46d094 (diff)
downloadaur-f8f81a18a224f2d154596943657ac5ae744c7dee.tar.gz
fix python/python2 thingy
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b3cc1ab0a08..bedab3fa56be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wiredtiger-git
pkgdesc = High performance, scalable, production quality, NoSQL, Open Source extensible platform for data management
- pkgver = 3.0.0.2.g574b928d7.19226
+ pkgver = 3.1.0r19536
pkgrel = 1
url = http://source.wiredtiger.com/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e2aac762f679..4ee85e639ee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=wiredtiger-git
-pkgver=3.0.0.2.g574b928d7.19226
+pkgver=3.1.0r19536
pkgrel=1
pkgdesc="High performance, scalable, production quality, NoSQL, Open Source extensible platform for data management"
arch=('x86_64')
@@ -16,7 +16,11 @@ md5sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- printf %s.%s $(git describe --tags | sed 's|-|.|g') $(git rev-list --count HEAD)
+ printf %sr%s $(git describe --tags | tr - .) $(git rev-list --count HEAD)
+}
+
+prepare() {
+ find ${pkgname%-git} -name "*.py" -exec sed -i '1s+python+python2+' {} \;
}
build() {