summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-10-24 21:11:59 +0200
committerNarrat2022-10-24 21:14:30 +0200
commit7660967f55c122da1c6b9ef06d64ea4a4285364e (patch)
tree3029d14458134a818bda02dc45ef2ae03d1aa631
parent996617bb8cfac6d4e8c11ba2915aa8d72597e671 (diff)
downloadaur-7660967f55c122da1c6b9ef06d64ea4a4285364e.tar.gz
wireguard-go: update to latest version
PKGBUILD based upon wireguard-go-git
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e538e1176e44..900a2c4481c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = wireguard-go
- pkgdesc = Go Implementation of WireGuard (not recommended by upstream, use official kernel module if possible)
- pkgver = 0.0.20180613
+ pkgdesc = Go userspace implementation of WireGuard
+ pkgver = 0.0.20220316
pkgrel = 1
url = https://git.zx2c4.com/wireguard-go/
+ arch = i686
+ arch = pentium4
arch = x86_64
- license = GPL2
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
makedepends = go
- depends = glibc
- optdepends = wireguard-tools: tools to configure WireGuard interfaces
- options = !strip
- options = !emptydirs
- source = https://git.zx2c4.com/wireguard-go/snapshot/wireguard-go-0.0.20180613.tar.xz
- source = 00-enable-on-linux.diff
- sha256sums = 3e22e6f2a715f05f9bbc5b1a9c737ab2edc8f26b2af61f9cc31f83391cd663ff
- sha256sums = e3780098f682e06480baefae4e4a30b0b179f033cb4e1bca4346c61172c457d8
+ source = https://git.zx2c4.com/wireguard-go/snapshot/wireguard-go-0.0.20220316.tar.xz
+ sha1sums = 9dbfef3009dc5da9c9f53a016049261db62c2ab8
pkgname = wireguard-go
-
diff --git a/PKGBUILD b/PKGBUILD
index 377920c517a4..fe05f97eda52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,23 @@
+# Contributor: Lex Black <autumn-wind@web.de>
+
pkgname=wireguard-go
-pkgver=0.0.20180613
+pkgver=0.0.20220316
pkgrel=1
-pkgdesc="Go Implementation of WireGuard (not recommended by upstream, use official kernel module if possible)"
-arch=('x86_64')
+pkgdesc="Go userspace implementation of WireGuard"
+arch=('i686' 'pentium4' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://git.zx2c4.com/wireguard-go/"
-license=('GPL2')
-depends=('glibc')
+license=('GPL')
makedepends=('go')
-optdepends=('wireguard-tools: tools to configure WireGuard interfaces')
-options=('!strip' '!emptydirs')
-source=("https://git.zx2c4.com/$pkgname/snapshot/$pkgname-$pkgver.tar.xz"
- "00-enable-on-linux.diff")
-sha256sums=('3e22e6f2a715f05f9bbc5b1a9c737ab2edc8f26b2af61f9cc31f83391cd663ff'
- 'e3780098f682e06480baefae4e4a30b0b179f033cb4e1bca4346c61172c457d8')
-
-prepare() {
- cd "$pkgname-$pkgver"
+source=(https://git.zx2c4.com/wireguard-go/snapshot/wireguard-go-0.0.20220316.tar.xz)
+sha1sums=('9dbfef3009dc5da9c9f53a016049261db62c2ab8')
- patch -p1 < "$srcdir"/00-enable-on-linux.diff
-}
build() {
cd "$pkgname-$pkgver"
-
- make
+ make DESTDIR="$pkgdir"
}
package() {
cd "$pkgname-$pkgver"
-
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}
-
-# vim:set ts=2 sw=2 et: