summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthomas2013-11-30 17:51:15 +0000
committerPetko Bordjukov2015-06-09 13:45:13 +0300
commit3cd89348d5d1f6fa1e1ab4fbc8fae684799d1265 (patch)
tree3c1bcb3c4fe13b3a8ef6fdec7e9c95f208177757
parent764a2d0b07e6e78d96458c5cad532cb43c5861c3 (diff)
downloadaur-3cd89348d5d1f6fa1e1ab4fbc8fae684799d1265.tar.gz
PKGBUILD updates
git-svn-id: file:///srv/repos/svn-packages/svn@200647 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD36
-rw-r--r--linville.key.pub.pem9
-rw-r--r--regulatory.bin.537
4 files changed, 10 insertions, 88 deletions
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 652a6dd672ac..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,16 +0,0 @@
-Copyright (c) 2008, Luis R. Rodriguez <mcgrof@gmail.com>
-Copyright (c) 2008, Johannes Berg <johannes@sipsolutions.net>
-Copyright (c) 2008, Michael Green <Michael.Green@Atheros.com>
-
-Permission to use, copy, modify, and/or distribute this software for any
-purpose with or without fee is hereby granted, provided that the above
-copyright notice and this permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-
diff --git a/PKGBUILD b/PKGBUILD
index 507643766f5b..dae190cb593a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,51 +2,35 @@
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=wireless-regdb
-pkgver=2013.01.11
+pkgver=2013.10.11
pkgrel=1
pkgdesc="Central Regulatory Domain Database"
arch=('any')
-url="http://wireless.kernel.org/en/developers/Regulatory/CRDA"
+url="http://wireless.kernel.org/en/developers/Regulatory"
backup=(etc/conf.d/wireless-regdom)
license=('custom')
-makedepends=('crda')
depends=('sh')
install=wireless-regdb.install
-source=(http://wireless.kernel.org/download/${pkgname}/regulatory.bins/${pkgver}-regulatory.bin
- linville.key.pub.pem
- regulatory.bin.5
- LICENSE
+source=(https://www.kernel.org/pub/software/network/wireless-regdb/${pkgname}-${pkgver}.tar.xz
crda.conf.d)
-sha256sums=('b1ee0b20c123c612dfdb6851ab42c01666f66fb583e0e590942f19bb54cf84be'
- '5d49ed0267082af35fd147a58434f19f7619518064b502b8a87143ee3e140546'
- 'f24bcaf67ecd088b407a9650375704a2fe1b23e3cfffbb1e7fe1026a02b3178a'
- '678b0df753c86198fc496d1f1033429bbd57f101472132ee7eaaf9f5e0a7fae1'
+sha256sums=('fdf2ad0b09dc820946dbd2816c2e7add3505f2ffe9022e0093ab702dc37073b9'
'192428fd959806705356107bffc97b8b379854e79bd013c4ee140e5202326e2b')
package() {
# Install and verify regulatory.bin file
msg "Installing and verifying the regulatory.bin file ..."
- install -D -m644 "${srcdir}"/${pkgver}-regulatory.bin "${pkgdir}"/usr/lib/crda/regulatory.bin
- # If crda is installed, the wireless regdb can be verified using regdbdump
- # Keep this step optional so no depend/makedepend loop is created
- if /usr/bin/regdbdump "${pkgdir}"/usr/lib/crda/regulatory.bin > /dev/null; then
- msg "Regulatory database verification was succesful."
- else
- error "Regulatory database verification failed."
- return 1
- fi
-
- install -D -m644 "${srcdir}"/linville.key.pub.pem "${pkgdir}"/usr/lib/crda/pubkeys/linville.key.pub.pem
- install -D -m644 "${srcdir}"/LICENSE "${pkgdir}"/usr/share/licenses/wireless-regdb/LICENSE
- install -D -m644 "${srcdir}"/regulatory.bin.5 "${pkgdir}"/usr/share/man/man5/regulatory.bin.5
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/regulatory.bin "${pkgdir}"/usr/lib/crda/regulatory.bin
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/linville.key.pub.pem "${pkgdir}"/usr/lib/crda/pubkeys/linville.key.pub.pem
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/LICENSE "${pkgdir}"/usr/share/licenses/wireless-regdb/LICENSE
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/regulatory.bin.5 "${pkgdir}"/usr/share/man/man5/regulatory.bin.5
msg "Installing /etc/conf.d/wireless-regdom ..."
install -D -m644 "${srcdir}"/crda.conf.d "${pkgdir}"/etc/conf.d/wireless-regdom
- for dom in $(/usr/bin/regdbdump "${pkgdir}"/usr/lib/crda/regulatory.bin | grep ^country | cut -d' ' -f2 | sed 's|:||g'); do
+ for dom in $(grep ^country "${srcdir}"/${pkgname}-${pkgver}/db.txt | cut -d' ' -f2 | sed 's|:||g'); do
echo "#WIRELESS_REGDOM=\"${dom}\"" >> "${pkgdir}"/etc/conf.d/wireless-regdom.tmp
done
sort -u "${pkgdir}"/etc/conf.d/wireless-regdom.tmp >> "${pkgdir}"/etc/conf.d/wireless-regdom
rm "${pkgdir}"/etc/conf.d/wireless-regdom.tmp
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/linville.key.pub.pem b/linville.key.pub.pem
deleted file mode 100644
index 3a2e8d0454e1..000000000000
--- a/linville.key.pub.pem
+++ /dev/null
@@ -1,9 +0,0 @@
------BEGIN PUBLIC KEY-----
-MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA1leZcYjTXc4qLq1oN2Ak
-8vLP85P5cFTrCpqdSI5W4VOwdaJB4TtaxU2fATcH/A2EsE3h1rOfzI0+fBV9DcOO
-qyID+zdILBMb8xK5Zv+78OkBGls/WzvDDVhdmn1TRHvRvmJy7cX1mCT56cnHrZM/
-ZBaFwVfiD9TcqqisyF1sqE5+cMHTWRbxc1+rtojr0eGYrNfK20awlD5KVj6Ejzot
-r9EDWAsL1bH/kGfMdnputcyMapLQpRVruO/jEdjSmhAE/sj1tmHcAXBT6j5al4Oa
-LiBaWnP++rune7rjimwfzp0549/rupQUM7nAZRDLyzXj3J/KEci6dXtjonBUFqDY
-4QIDAQAB
------END PUBLIC KEY-----
diff --git a/regulatory.bin.5 b/regulatory.bin.5
deleted file mode 100644
index 430c65c9ce6d..000000000000
--- a/regulatory.bin.5
+++ /dev/null
@@ -1,37 +0,0 @@
-.TH regulatory.bin 5 "23 January 2009" "regulatory.bin" "Linux"
-.SH NAME
-regulatory.bin \- The Linux wireless regulatory database
-
-.ad l
-.in +8
-.ti -8
-
-.SS
-.SH Description
-.B regulatory.bin
-is the file used by the Linux wireless subsystem to keep its regulatory
-database information. It is read by
-.B crda
-upon the Linux kernel's request for regulatory information for a specific
-ISO / IEC 3166 alpha2 country code. The regulatory database is kept in
-a small binary format for size and code efficiency. The
-.B regulatory.bin
-file can be parsed and read in human format by using the
-.B regdbdump
-command. The
-.B regulatory.bin
-file should be updated upon regulatory changes or corrections.
-
-.SH Upkeeping
-The regulatory database is maintained by the community as such
-you are encouraged to send any corrections or updates to the
-linux-wireless mailing list:
-.B linux-wireless@vger.kernel.org
-
-.SH SEE ALSO
-.BR regdbdump (8)
-.BR crda (8)
-.BR iw (8)
-
-.BR http://wireless.kernel.org/en/developers/Regulatory/
-