summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-07 16:59:09 +1200
committercaltlgin2020-09-07 16:59:09 +1200
commit4b46080605dbc8dc8b0ba9497a58696f2a230b68 (patch)
tree523976348efe7f4836c537cb68aadcb357110e3b
parentd34e9d86eb45a5808b19be9fb704da9b6f44df52 (diff)
downloadaur-4b46080605dbc8dc8b0ba9497a58696f2a230b68.tar.gz
Add depends=(python-pyaml)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d05daa5b06c4..86623a18bba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = wireviz
pkgdesc = Easily document cables, wiring harnesses and connector pinouts
pkgver = 0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/formatc1702/WireViz
arch = any
license = GPL3
makedepends = python-setuptools
+ depends = python
depends = python-graphviz
+ depends = python-pyaml
source = https://files.pythonhosted.org/packages/source/w/wireviz/wireviz-0.1.tar.gz
sha256sums = 851a6d3a5302b0a41659b7622500c7b8edf7005f3ec88a823f2d207feee7ebf7
diff --git a/PKGBUILD b/PKGBUILD
index b6f9754d3d7e..a4b21b366602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname=wireviz
+pkgname='wireviz'
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Easily document cables, wiring harnesses and connector pinouts'
arch=('any')
url='https://github.com/formatc1702/WireViz'
license=('GPL3')
-depends=('python-graphviz')
+depends=('python' 'python-graphviz' 'python-pyaml')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('851a6d3a5302b0a41659b7622500c7b8edf7005f3ec88a823f2d207feee7ebf7')
@@ -20,7 +20,7 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
}
# vim: ts=2 sw=2 et: