summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-06-24 19:35:41 +0200
committerkleintux2022-06-24 19:35:41 +0200
commitc99c0e8057ed1d2d224870e2669931efb6d12907 (patch)
tree1eed1d36e40a68bccb88b4c0d628d5dd8693e3e6
parent93c50ac8d7d3d66c4e5a2cb8dc6166f79417f998 (diff)
downloadaur-c99c0e8057ed1d2d224870e2669931efb6d12907.tar.gz
adopted. updated to 0.3.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b98bf7b56111..745e7ec919d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wireviz
pkgdesc = Easily document cables, wiring harnesses and connector pinouts
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.3.2
+ pkgrel = 1
url = https://github.com/formatc1702/WireViz
arch = any
license = GPL3
@@ -10,8 +10,7 @@ pkgbase = wireviz
depends = python-graphviz
depends = python-pillow
depends = python-pyaml
- source = wireviz::git+https://github.com/formatc1702/WireViz.git#tag=v0.2
- sha256sums = SKIP
+ source = https://github.com/formatc1702/WireViz/archive/refs/tags/v0.3.2.tar.gz
+ sha256sums = bd2af9b6357bb2324a0db4b4efad4182ac0ea62d8f57ea55ac477428ea45e652
pkgname = wireviz
-
diff --git a/PKGBUILD b/PKGBUILD
index a1443c8808f0..35f1fdc7a498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname='wireviz'
-pkgver=0.2
-pkgrel=2
+pkgname=wireviz
+_pkgname=WireViz
+pkgver=0.3.2
+pkgrel=1
pkgdesc='Easily document cables, wiring harnesses and connector pinouts'
arch=('any')
url='https://github.com/formatc1702/WireViz'
@@ -10,16 +12,16 @@ _url_pypi='https://pypi.org/project/wireviz'
license=('GPL3')
depends=('python-graphviz' 'python-pillow' 'python-pyaml')
makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+${url}.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/formatc1702/WireViz/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('bd2af9b6357bb2324a0db4b4efad4182ac0ea62d8f57ea55ac477428ea45e652')
build() {
- cd "${pkgname}"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${pkgname}"
+ cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dvm644 'docs/'*.md -t "${pkgdir}/usr/share/doc/${pkgname}"
cp -rfv 'examples' 'tutorial' "${pkgdir}/usr/share/doc/${pkgname}"