summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-07-31 10:40:17 +1200
committercaltlgin2020-07-31 10:40:17 +1200
commitd34e9d86eb45a5808b19be9fb704da9b6f44df52 (patch)
tree078fc59dc82e68c034a6d0d101e8d23c360d8dff
downloadaur-d34e9d86eb45a5808b19be9fb704da9b6f44df52.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d05daa5b06c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wireviz
+ pkgdesc = Easily document cables, wiring harnesses and connector pinouts
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/formatc1702/WireViz
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-graphviz
+ source = https://files.pythonhosted.org/packages/source/w/wireviz/wireviz-0.1.tar.gz
+ sha256sums = 851a6d3a5302b0a41659b7622500c7b8edf7005f3ec88a823f2d207feee7ebf7
+
+pkgname = wireviz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6f9754d3d7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=wireviz
+pkgver=0.1
+pkgrel=1
+pkgdesc='Easily document cables, wiring harnesses and connector pinouts'
+arch=('any')
+url='https://github.com/formatc1702/WireViz'
+license=('GPL3')
+depends=('python-graphviz')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('851a6d3a5302b0a41659b7622500c7b8edf7005f3ec88a823f2d207feee7ebf7')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: