summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Bero2015-09-22 20:45:10 -0500
committerChristopher Bero2015-09-22 20:45:10 -0500
commit54bf315488739f6bce64672d7bd0c492de3ad4c2 (patch)
tree9e5d85af96b71e3fadff1601f479378ffb0f9932
parentedfe6f3e7e3815680050686fa1266043926e7312 (diff)
downloadaur-54bf315488739f6bce64672d7bd0c492de3ad4c2.tar.gz
updated PKGBUILD, tested to build
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18c4507d498f..8464612a99f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,19 +26,25 @@ md5sums=() #autofill using updpkgsums
#}
package() {
- cp gpio_halt.sh /usr/bin/gpio_halt
- cp gpio_halt.service /etc/systemd/system/gpio_halt.service
+ install -D ../gpio_halt.sh "${pkgdir}/usr/bin/gpio_halt"
+ install -D ../gpio_halt.service "${pkgdir}/etc/systemd/system/gpio_halt.service"
- systemctl daemon-reload
+ #systemctl daemon-reload
#systemctl enable gpio_halt.service
echo "=="
echo "== This package defaults to gpio pin 4 (header 7) and ground."
echo "== If you choose a different pin, edit /usr/bin/gpio_halt"
echo "=="
+ echo "== Make sure the spst switch is connected from ground to the"
+ echo "== specified header. Then continue:"
+ echo "=="
echo "== The service is not active, make sure to run:"
- echo "== systemctl daemon-reload"
- echo "== systemctl enable gpio_halt.service"
+ echo "== $ systemctl daemon-reload"
+ echo "== $ systemctl enable gpio_halt.service"
+ echo "=="
+ echo "== Holding the button for >=6 seconds and releasing will then"
+ echo "== cause the system to safely shutdown."
echo "=="
}