summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2019-12-29 16:19:35 +0100
committerBlair Bonnett2019-12-29 16:19:35 +0100
commit761855f2c86d58485a3be6ff9f23b98fc7dcaae8 (patch)
tree5f0858d07a5632d4efb5f3612e9ba4ae3e6a15cd
parente641dee169afca0d0ef612df974ba0c44236c17f (diff)
downloadaur-761855f2c86d58485a3be6ff9f23b98fc7dcaae8.tar.gz
Fix makedepends; bring version reported by Python in line with package.
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
-rw-r--r--python3.patch7
-rw-r--r--timeout.patch2
5 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e512d28d94..9f91abad9213 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = wispr
pkgdesc = Simple command-line tool to authenticate against a WISPr server
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/wichert/wispr
arch = any
license = custom
+ makedepends = python-setuptools
depends = python
- source = https://github.com/wichert/wispr/archive/release/1.0.tar.gz
+ source = wispr-1.0.tar.gz::https://github.com/wichert/wispr/archive/release/1.0.tar.gz
source = python3.patch
source = timeout.patch
sha256sums = ba9994abee90d51c9d65fbb61241694a610a0198c5c4a833f8d7bf9c346ebd41
- sha256sums = 7f14a07b35f7625b90163352ef943d225ef4ba01a5aa172e67174157e1b4b2cf
- sha256sums = 0cc5f11d022ff3c560f71ce7c7269dd55a50a31ba1ee9c230e0405801b777eb5
+ sha256sums = 191677eac9a175c56cff40f7e41843e21660be2de5be3aab2c926d0f3f7bf6e6
+ sha256sums = 2af11c057fceb909cfecbd08a63fcd8efcfa4fe6f94c70dc5e897b4d47435ec8
pkgname = wispr
diff --git a/.gitignore b/.gitignore
index dbf3fdd9285b..ce0c44eaf5c1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
src
pkg
*.pkg.tar.xz
+*.pkg.tar.zst
*.tar.gz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 3e28ad7858c2..a5aaaaea97e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
pkgname=wispr
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Simple command-line tool to authenticate against a WISPr server"
url="https://github.com/wichert/wispr"
arch=('any')
license=('custom')
-depends=('python')
+depends=(python)
+makedepends=(python-setuptools)
source=(
- 'https://github.com/wichert/wispr/archive/release/1.0.tar.gz'
+ "wispr-${pkgver}.tar.gz::https://github.com/wichert/wispr/archive/release/${pkgver}.tar.gz"
'python3.patch'
'timeout.patch'
)
sha256sums=(
'ba9994abee90d51c9d65fbb61241694a610a0198c5c4a833f8d7bf9c346ebd41'
- '7f14a07b35f7625b90163352ef943d225ef4ba01a5aa172e67174157e1b4b2cf'
- '0cc5f11d022ff3c560f71ce7c7269dd55a50a31ba1ee9c230e0405801b777eb5'
+ '191677eac9a175c56cff40f7e41843e21660be2de5be3aab2c926d0f3f7bf6e6'
+ '2af11c057fceb909cfecbd08a63fcd8efcfa4fe6f94c70dc5e897b4d47435ec8'
)
prepare() {
@@ -32,6 +33,6 @@ build() {
package() {
cd "wispr-release-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/python3.patch b/python3.patch
index 858cbfaf93d9..3096ddf1f594 100644
--- a/python3.patch
+++ b/python3.patch
@@ -1,13 +1,16 @@
diff -Naur wispr-release-1.0/changes.rst wisprpy3/changes.rst
--- wispr-release-1.0/changes.rst 1970-01-01 01:00:00.000000000 +0100
+++ wisprpy3/changes.rst 2019-02-15 06:22:13.418704328 +0100
-@@ -0,0 +1,13 @@
+@@ -0,0 +1,16 @@
+Changelog
+=========
+
+1.1 - Unreleased
+--------------------
+
++The following features have been back-ported to 1.0 for the package in the
++Arch Linux User Repository (AUR):
++
+- Support Python 3 as well.
+
+
@@ -23,7 +26,7 @@ diff -Naur wispr-release-1.0/setup.py wisprpy3/setup.py
from setuptools import setup
-version = '1.0'
-+version = '1.1'
++version = '1.0.post4'
setup(
version=version,
diff --git a/timeout.patch b/timeout.patch
index a52d594df7da..886b867dbfcb 100644
--- a/timeout.patch
+++ b/timeout.patch
@@ -1,7 +1,7 @@
diff -Naur wisprpep8/changes.rst wisprtimeout/changes.rst
--- wisprpep8/changes.rst 2019-02-15 06:27:03.836857275 +0100
+++ wisprtimeout/changes.rst 2019-02-15 06:25:46.474801521 +0100
-@@ -6,6 +6,8 @@
+@@ -9,6 +9,8 @@
- Support Python 3 as well.