summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2021-03-20 10:41:41 +0100
committerDavide Depau2021-03-20 10:41:41 +0100
commite0a5fd3161e81de170d2349999b96c82eaf260ef (patch)
tree617eb61cd7132c780c2b625d653ca7fbf6d76f55
downloadaur-e0a5fd3161e81de170d2349999b96c82eaf260ef.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d01df334cc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wistty
+ pkgdesc = Set remote terminal parameters for Wi-Se
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Depau/wi-se-sw
+ arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = go
+ source = git+https://github.com/Depau/ttyc.git#tag=wistty-v0.1
+ sha256sums = SKIP
+
+pkgname = wistty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c26d24d7d05f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_srcname=ttyc
+pkgname=wistty
+pkgver=0.1
+pkgrel=1
+pkgdesc='Set remote terminal parameters for Wi-Se'
+arch=('x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
+url="https://github.com/Depau/wi-se-sw"
+license=('GPL3')
+makedepends=('go')
+source=("git+https://github.com/Depau/ttyc.git#tag=wistty-v${pkgver}")
+sha256sums=('SKIP')
+
+prepare(){
+ cd "$_srcname"
+ mkdir -p build/
+}
+
+build() {
+ cd "$_srcname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./cmd/wistty
+}
+
+package() {
+ cd "$_srcname"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}