summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhazard2015-07-25 00:54:56 -0700
committerhazard2015-07-25 00:54:56 -0700
commitb9d6cd7ba0d7588fe431b92c49e280b1e0d08c17 (patch)
tree5dba40d162b3bde982024291ca7b99dba6f84d93
downloadaur-b9d6cd7ba0d7588fe431b92c49e280b1e0d08c17.tar.gz
Package withlock submitted by aurpush
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce7795128593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = withlock
+ pkgdesc = A locking wrapper script to make sure that some program is not run more than once
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://github.com/poeml/withlock
+ arch = any
+ license = Apache
+ depends = python2
+ provides = withlock
+ source = https://github.com/poeml/withlock/archive/master.tar.gz
+ md5sums = 18f2c2cb6f7b6356113a7f641d1d5cb3
+
+pkgname = withlock
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9881fec21af4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e941ab303201
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: OS Hazard <oshazard+aur@gmail.com>
+pkgname=withlock
+pkgver=0.4
+pkgrel=1
+pkgdesc="A locking wrapper script to make sure that some program is not run more than once"
+url="http://github.com/poeml/withlock"
+license="Apache"
+arch=('any')
+makedepends=('')
+depends=('python2')
+provides=('withlock')
+source=("https://github.com/poeml/withlock/archive/master.tar.gz")
+md5sums=('18f2c2cb6f7b6356113a7f641d1d5cb3')
+
+package() {
+ cd "${srcdir}/withlock-master"
+
+ # Install script
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 withlock "$pkgdir/usr/bin/withlock"
+
+ # Install license
+ mkdir -p "${pkgdir}/usr/share/licenses/withlock"
+ install -m644 LICENSE-2.0.txt ${pkgdir}/usr/share/licenses/withlock/LICENSE
+}