summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamren2024-01-12 20:01:32 -0500
committerCamren2024-01-12 20:01:32 -0500
commit8a459d62fcb29cde459b7fe4c7b86c53b3be684e (patch)
tree0d0ee2c330d32996007d9beaf4a85ce7e7417be9
downloadaur-8a459d62fcb29cde459b7fe4c7b86c53b3be684e.tar.gz
bump to 0.10.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea268fb50511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wivrn-server
+ pkgdesc = A wireless Monado-based OpenXR runtime for standalone headsets.
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = https://github.com/Meumeu/WiVRn
+ arch = x86_64
+ license = GPL-3-only
+ makedepends = cmake
+ depends = x264
+ depends = eigen
+ depends = libpulse
+ depends = avahi
+ depends = nlohmann-json
+ optdepends = ffmpeg: AMD/Intel hardware encoding,
+ optdepends = cuda: NVIDIA hardware encoding
+ provides = openxr-runtime
+ source = wivrn-server-0.10.2::git+https://github.com/Meumeu/WiVRn.git#tag=v0.10.2
+ sha256sums = SKIP
+
+pkgname = wivrn-server
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..546d1da0f091
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Camren Mumme <camren.mumme@gmail.com>
+pkgname=wivrn-server
+pkgver=0.10.2
+pkgrel=1
+pkgdesc="A wireless Monado-based OpenXR runtime for standalone headsets."
+arch=(x86_64)
+url="https://github.com/Meumeu/WiVRn"
+license=("GPL-3-only")
+depends=(
+ "x264"
+ "eigen"
+ "libpulse"
+ "avahi"
+ "nlohmann-json"
+)
+makedepends=("cmake")
+optdepends=(
+ "ffmpeg: AMD/Intel hardware encoding",
+ "cuda: NVIDIA hardware encoding"
+)
+provides=("openxr-runtime")
+source=("$pkgname-$pkgver::git+https://github.com/Meumeu/WiVRn.git#tag=v$pkgver")
+sha256sums=("SKIP")
+
+_use_nvenc=OFF
+
+prepare() {
+ # Use NVENC if cuda is installed. Build errors if compiled with
+ # DWIVRN_USE_NVENC on non-nvidia system. (or it's just broken,
+ # I don't have a nvidia system to test on)
+ # TODO: Find a better way to do this?
+ _use_nvenc=[[ $(pacman -Q cuda) = "" ]] && echo "OFF" || echo "ON"
+ echo "Build with NVENC: $_use_nvenc"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -B build-server . -GNinja \
+ -DWIVRN_BUILD_CLIENT=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DWIVRN_USE_VAAPI=ON \
+ -DWIVRN_USE_X264=ON \
+ -DWIVRN_USE_NVENC=$_use_nvenc \
+ -Wno-dev
+
+ cmake --build build-server
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" cmake --install build-server
+}