summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon2016-05-14 22:25:30 +0800
committerLeon2016-05-14 22:39:28 +0800
commitfae5fedbf3a787f1e4d9a3865ebbf0d32382f8f8 (patch)
tree936a4c1338d07dc4dfe30334eb45458143b8ebad
downloadaur-wiznote-qt4.tar.gz
v2.3.3
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
-rw-r--r--wiznote.install12
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..352d76334658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 5.0.1
+# Sat May 14 14:16:05 UTC 2016
+pkgbase = wiznote-qt4
+ pkgdesc = Opensource cross-platform cloud based note-taking client
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = http://www.wiznote.com
+ install = wiznote.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ makedepends = boost
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = crypto++
+ depends = qtwebkit
+ provides = wiznote=2.3.3
+ conflicts = wiznote
+ source = git+https://github.com/WizTeam/WizQTClient.git#branch=v2.3.3
+ md5sums = SKIP
+
+pkgname = wiznote-qt4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00133f86c8f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!wiznote.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d57544e44116
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Leon <leon.tty1 at gmail dot com>
+# Contributor: proudzhu <proudzhu.fdu at gmail.com>
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: Albert.Zhou <albert.zhou@wiz.cn>
+
+pkgname=wiznote-qt4
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="Opensource cross-platform cloud based note-taking client"
+arch=('i686' 'x86_64')
+url="http://www.wiznote.com"
+license=('GPL3' 'custom')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'crypto++' 'qtwebkit')
+# shared clucene/quazip triggers segfault
+makedepends=('cmake' 'git' 'boost')
+conflicts=('wiznote')
+provides=(wiznote=$pkgver)
+install=wiznote.install
+_wiznote_project_name="WizQTClient"
+source=("git+https://github.com/WizTeam/${_wiznote_project_name}.git#branch=v2.3.3")
+md5sums=('SKIP')
+
+prepare() {
+ rm -f $_wiznote_project_name/share/skins/default/Thumbs.db
+
+ sed -e 's/add_subdirectory(cryptopp)//' \
+ -i $_wiznote_project_name/lib/CMakeLists.txt
+
+ sed -e 's/cryptlib/cryptopp/' \
+ -i $_wiznote_project_name/src/CMakeLists.txt
+
+ rm -rf build; mkdir build
+}
+
+build() {
+ cd build
+
+ # qt5 version is unusable
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ../$_wiznote_project_name
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/wiznote.install b/wiznote.install
new file mode 100644
index 000000000000..d43ea7c35e25
--- /dev/null
+++ b/wiznote.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}